Closed Bug 1496189 Opened 11 months ago Closed 11 months ago

Password quality meter show always undetermined

Categories

(Firefox :: Preferences, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 64
Tracking Status
firefox-esr60 --- unaffected
firefox62 --- unaffected
firefox63 --- unaffected
firefox64 + fixed

People

(Reporter: Paenglab, Assigned: surkov)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image passwordQuality.png
In FX preferences "Change Master Password" dialog the password quality meter shows always undetermined and not the strength progress. Also does the green bar not use the full height.

The same happens to Thunderbird's account quota meter.
(In reply to Richard Marti (:Paenglab) from comment #0)
> Created attachment 9014124 [details]
> passwordQuality.png
> 
> In FX preferences "Change Master Password" dialog the password quality meter
> shows always undetermined and not the strength progress. Also does the green
> bar not use the full height.
> 
> The same happens to Thunderbird's account quota meter.

which os x this is?
(In reply to alexander :surkov (:asurkov) from comment #1)
> (In reply to Richard Marti (:Paenglab) from comment #0)
> > Created attachment 9014124 [details]
> > passwordQuality.png
> > 
> > In FX preferences "Change Master Password" dialog the password quality meter
> > shows always undetermined and not the strength progress. Also does the green
> > bar not use the full height.
> > 
> > The same happens to Thunderbird's account quota meter.
> 
> which os x this is?

no 'x' for sure :)
Windows 10.
[Tracking Requested - why for this release]:
Functionality regression that needs fixing for Fx64 so we don't ship it.

:surkov, are you able to pick this up? :-)
Flags: needinfo?(surkov.alexander)
Priority: -- → P1
On Linux no progress is shown in the master password dialog. Only the empty progressmeter container.
QA Contact: jaws
QA Contact: jaws
(In reply to :Gijs (he/him) from comment #4)
> [Tracking Requested - why for this release]:
> Functionality regression that needs fixing for Fx64 so we don't ship it.
> 
> :surkov, are you able to pick this up? :-)

I guess I should. The trickiest part is I don't have ready-to-work linux/win machines at hands to debug the thing.
Flags: needinfo?(surkov.alexander)
Attached patch patchSplinter Review
Assignee: nobody → surkov.alexander
Attachment #9015188 - Flags: review?(paolo.mozmail)
Comment on attachment 9015188 [details] [diff] [review]
patch

This works on Windows and Linux.
(In reply to Richard Marti (:Paenglab) from comment #8)
> Comment on attachment 9015188 [details] [diff] [review]
> patch
> 
> This works on Windows and Linux.

Thank you so much for checking it!
Comment on attachment 9015188 [details] [diff] [review]
patch

Ah, whoops! Didn't notice this was inverted when reviewing the patch.
Attachment #9015188 - Flags: review?(paolo.mozmail) → review+
Pushed by surkov.alexander@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ccbd30a9a23a
Password quality meter show always undetermined, r=paolo
Duplicate of this bug: 1496861
https://hg.mozilla.org/mozilla-central/rev/ccbd30a9a23a
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Depends on: 1498075
Depends on: 1498140
Depends on: 1499116
I Have reproduced this bug with Nightly 64.0a1 (2018-10-03) on Windows 7, 64 Bit!
This bug's fix is verified with latest Beta!

Build ID 	20181108141956
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0
QA Whiteboard: [testday20181109]
You need to log in before you can comment on or make changes to this bug.