Closed Bug 1496246 Opened Last year Closed Last year

Update Pocket CTA implementation with feedback from Legal and UX

Categories

(Firefox :: New Tab Page, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 64
Iteration:
64.3 - Oct 12
Tracking Status
firefox63 + wontfix
firefox64 + verified
firefox65 --- verified

People

(Reporter: nchapman, Assigned: thecount)

References

Details

Attachments

(4 files)

There are a few minor tweaks we need to make to the Pocket CTA implementation on new tab based on the feedback we received from our legal and UX teams.

1. Update "Learn more" to "How it works"
2. Move "How it works" to the right of the collapse arrow.
3. Change CTA button color to Blue 60.
4. Update CTA text to match the link styling of "More Recommendations >".

Updated Invision spec:

https://mozilla.invisionapp.com/share/AMNI4YWRJK6#/screens
Testing steps for QA:

1. In about:config, set browser.newtabpage.activity-stream.pocketCta to:
   {"cta_button":"","cta_text":"","cta_url":"","use_cta":true}

2. With a profile that is NOT signed-in to sync, ensure CTA is showing ("Get Pocket") below pocket and the design matches the above spec (see bug description.

3. Sign into sync. Ensure text below pocket matches design spec above (should say Trending topics etc.)
QA Contact: tspurway
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/b5d2ce26a4f1a0d071ba1b84c0150806ad99f9a2
bug 1496246 - Update Pocket CTA implementation with feedback from Legal and UX (#4470)
QA Contact: tspurway
flod, sounds like this change will want to be uplifted to 63, so we'll export to mozilla-central ASAP to hopefully get strings translated in time before 63rc uplifted via bug 1496807. Although it seems unlikely to happen in time for de as the pocket strings being replaced were only just translated for German this week.

nchapman, if we can't get de strings in time, should it just show the English "How it works" one (which would be the default behavior if this gets uplifted). Or somehow figure out a way to show the "undesired-by-legal-and-ux" old UI ("Learn more"). See next attachment. Or perhaps an in-between is use the "Learn more" string instead of "How it works" with new UI placement?
Flags: needinfo?(nchapman)
See Also: → 1496807
I would strongly suggest to keep the existing (translated) string for 63.
Blocks: 1496457
Thanks for raising the translation issue! Just checked with folks, and we can leave the string as "Learn more" for 63 as long as we update it to "How it works" in 64.
Flags: needinfo?(nchapman)
https://hg.mozilla.org/mozilla-central/rev/4a0b6cfb51a1
Status: NEW → RESOLVED
Iteration: --- → 64.3 (Oct 12)
Closed: Last year
Priority: -- → P1
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Assignee: nobody → sdowne
Scott, why did you request relman tracking for 63? Was it for the l10n issue mentioned in comment #4? Given that we won't uplift the patch (comment #7) it seems we don't need to track it. Also, since it landed in Nightly 64, why are you asking this bug to be tracked for 64? Is there a specific risk about the patch that we need to take into account for the upcoming 64 release? Thanks
Flags: needinfo?(sdowne)
I believe comment 7 was saying to keep the existing translated German string ("Learn more") for 63 as the new UI with the patch for this bug would have needed a new string that wouldn't be ready in time for 63 uplift this week.
Pascal, yeah sorry, we wanted to uplift this whole bug very soon, but the l10n flags got raised.

At this point I think we still want to uplift most of these changes, but just leave behind the string change. I'm not sure how to go about creating an uplift for that quite yet. Any advice is appreciated. Example, can I just omit the string changes in this patch via the uplift, keeping nightly the same, or is that risky?
Flags: needinfo?(sdowne)
thecount, we'll just uplift the changes here normally. The way I structured the patch in bug 1496807 has a german string for pocket_how_it_works
Comment on attachment 9015378 [details]
bug 1496246 - Update Pocket CTA implementation with feedback from Legal and UX

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1483655

User impact if declined: User experience and legal affected.

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: Yes

If yes, steps to reproduce: Just check that:

1. Update "Learn more" to "How it works"
2. Move "How it works" to the right of the collapse arrow.
3. Change CTA button color to Blue 60.
4. Update CTA text to match the link styling of "More Recommendations >".
5. DE string for "How it works" should display as "Weitere Informationen" which is German for "Learn more"

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): It's just html and css changes at this point. Automated tests not required.

String changes made/needed: Kinda, it's been dealt with in ticket 1496807 though.
Attachment #9015378 - Flags: approval-mozilla-beta?
I have verified this issue and I can confirm that the steps from 1 to 4 are fixed in the latest Nightly build (64.0a1 Build ID - 20181008220129) on Windows 10 x64, Arch Linux and Mac 10.13.3.
@Scott, could you please confirm that the above steps are all we can verify in this issue, given the fact that at step 5 we are blocked by Bug 1496807?
Flags: needinfo?(sdowne)
Comment on attachment 9015378 [details]
bug 1496246 - Update Pocket CTA implementation with feedback from Legal and UX

Low risk, uplift approved for 63 beta 14, thanks.
Attachment #9015378 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
Hey Marius, I think step 5 can be tested on nightly at least as I think #1496807 is on nightly already, and should land before this one on beta? I'll double check this to be sure.
Flags: needinfo?(sdowne)
(In reply to Ed Lee :Mardak from comment #12)
> thecount, we'll just uplift the changes here normally. The way I structured
> the patch in bug 1496807 has a german string for pocket_how_it_works

But you just landed a new string in Beta, exposed to localization, and that's far from OK.
https://hg.mozilla.org/releases/mozilla-beta/rev/080751e04de5#l311.1

It will trigger sign-offs for all languages, 24 hours from deadline, and make my life quite miserable (and backing out would not fix that either).

But we should avoid showing 1 string missing to 100 languages, when they can't do anything about it.
Flags: needinfo?(edilee)
Can we get the changes to newtab.properties reverted, whatever it requires?
Flags: needinfo?(sdowne)
Sorry again. Reverted newtab.properties l10n change https://hg.mozilla.org/releases/mozilla-beta/rev/61227c732eef
Flags: needinfo?(sdowne)
Flags: needinfo?(edilee)
See Also: → 1497565
Considering the fact that the "How it works" string is not approved yet in "Pontoon" for the "DE" locale, I will leave a need info on myself in order to verify this issue once the string will be approved.
Flags: needinfo?(marius.coman)
See Also: → as-build-beta-script
I have tested this issue with the latest Firefox Beta DE locale build (64.0b13 Build ID - 20181126173133) and with the latest Firefox Nightly DE locale (65.0a1 Build ID - 20181127100134) installed, on Windows 10 x64, Arch Linux and Mac 10.13.3. 

It seems that the "How it works" string is still displayed in English instead of German even if it is translated and approved in "Pontoon" (https://goo.gl/LftwVC).
Considering the above I am reopening this issue.
Status: RESOLVED → REOPENED
Flags: qe-verify+
Flags: needinfo?(marius.coman)
Resolution: FIXED → ---
The DE string has not been uplifted to beta 64 yet. It's pending approval in bug 1508409 comment 6.

For Nightly 65, it's getting the string in the latest export bug 1510040 as the DE string was just approved in pontoon a couple days ago.

Could you check on beta and nightly when those respective bugs are fixed?
Flags: needinfo?(marius.coman)
See Also: → 1508409, 1510040
Sure, I will leave this ni? on me until then.
Status: REOPENED → RESOLVED
Closed: Last yearLast year
Flags: needinfo?(marius.coman)
Resolution: --- → FIXED
I have verified that this issue is no longer reproducible with the latest Firefox Beta DE locale build (64.0 Build ID - 20181203202653) and with the latest Firefox Nightly DE locale build (65.0a1 Build ID - 20181204215402) installed, on Windows 10 x64, Arch Linux and Mac 10.13.3. Now, the "How it works" string is displayed in German.
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.