Closed Bug 1496341 Opened Last year Closed 9 months ago

Run debugger tests on try

Categories

(DevTools :: Debugger, defect, P3)

defect

Tracking

(firefox67 fixed)

RESOLVED FIXED
Firefox 67
Tracking Status
firefox67 --- fixed

People

(Reporter: Honza, Assigned: jlast)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

This is a follow up for Bug 1461714

All existing Mocha tests for Debugger should run automatically on Try too, so changes made through m-c are properly tested.

This can be done through one special mochitest that uses nodejs to execute mocha test runner.

Honza
Depends on: node-debugger
Priority: -- → P2
Summary: Run all Debugger Mocha test on Try → Run all Debugger Mocha tests on Try
Blocks: node-dx
Priority: P2 → P3
Summary: Run all Debugger Mocha tests on Try → Run all Debugger Jest tests on Try
Duplicate of this bug: 1313542
Summary: Run all Debugger Jest tests on Try → Run debugger tests on Try
Summary: Run debugger tests on Try → Run debugger tests on try
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/73298bafb7ae
Run debugger tests on try. r=loganfsmyth,ahal
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Assignee: nobody → jlaster
You need to log in before you can comment on or make changes to this bug.