Use mozlog for node debugger linting test

RESOLVED FIXED in Firefox 68

Status

defect
P3
normal
RESOLVED FIXED
2 months ago
4 days ago

People

(Reporter: aryx, Assigned: jdescottes)

Tracking

(Depends on 1 bug, Blocks 1 bug)

unspecified
Firefox 68
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(2 attachments)

Bug 1496341 added the node(debugger) job which lints devtools/client/debugger/new/

https://searchfox.org/mozilla-central/source/taskcluster/ci/source-test/node.yml

The linting failures of that job are not properly formatted with the mozlog format (no TEST-UNEXPECTED-FAIL or TEST-UNEXPECTED-ERROR) and thus Treeherder and its log viewer don't show a summary what is wrong with the job.

Example: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&selectedJob=233996724&revision=ee3da141383532c5f82be55ea74fc5e0b4622ec8

https://firefox-source-docs.mozilla.org/mozbase/mozlog.html

See mach's treeherder parameter usage for the ESlint job:
https://searchfox.org/mozilla-central/rev/f1c7ba91fad60bfea184006f3728dd6ac48c8e56/taskcluster/ci/source-test/mozlint.yml#63-68

Flags: needinfo?(jlaster)
Blocks: node-dx
Flags: needinfo?(jlaster)
No longer blocks: node-dx
Priority: -- → P3

Comment 1

27 days ago
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/3b274cabedb6
Switch node devtools and debugger tasks to tier 3 until they provide structured failure output. a=tasks-without-failure-summary DONTBUILD

The node(debugger) and node(devtools) task have been switched to Tier 3 because they don't provide failures in a format which gets picked up by the failure summary generation and one has to always look into the raw log what went wrong. Until this is fixed, the jobs will not be sheriffed.

Flags: needinfo?(odvarko)
Keywords: leave-open
See Also: → 1546370
Duplicate of this bug: 1535022

Comment 6

26 days ago
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f8f02e7922a5
Use mozlog for node debugger linting test. r=jdescottes
Depends on: 1546665
Flags: needinfo?(odvarko)
(Assignee)

Comment 8

10 days ago

I will add a patch to fix this for the devtools suite as well now.

Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Keywords: leave-open

Comment 11

10 days ago
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f005c5114e06
Add proper logs for node-devtools test suite r=jlast

Backed out for node devtools failures.

backout: https://hg.mozilla.org/integration/autoland/rev/5003c4244ea22c6a1337b3716bc641cb17891638

push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=f005c5114e062c9ad0a5552784a97b56488f81a4&searchStr=linux%2Cx64%2Copt%2Cnode%2Ctests%2Csource-test-node-devtools-tests%2Cnode%28devtools%29

failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=245756720&repo=autoland&lineNumber=346

[task 2019-05-10T14:40:54.804Z] TEST START | mocha | webconsole
[task 2019-05-10T14:40:54.804Z] [devtools-node-test-runner] Run yarn test in test folder
[task 2019-05-10T14:40:58.659Z] warning package.json: No license field
[task 2019-05-10T14:40:58.659Z] Warning: Each child in an array or iterator should have a unique "key" prop.
[task 2019-05-10T14:40:58.659Z]
[task 2019-05-10T14:40:58.659Z] Check the top-level render call using <span>. See https://fb.me/react-warning-keys for more information.
[task 2019-05-10T14:40:58.659Z] in Unknown
[task 2019-05-10T14:40:58.659Z] Warning: Failed prop type: MessageIcon: prop type onRewindClick is invalid; it must be a function, usually from the prop-types package, but received undefined.
[task 2019-05-10T14:40:58.659Z] in MessageIcon
[task 2019-05-10T14:40:58.659Z] error Command failed with exit code 1.
[task 2019-05-10T14:40:58.659Z] [devtools-node-test-runner] Error log
[task 2019-05-10T14:40:58.660Z] warning package.json: No license field
[task 2019-05-10T14:40:58.660Z] Warning: Each child in an array or iterator should have a unique "key" prop.
[task 2019-05-10T14:40:58.660Z]
[task 2019-05-10T14:40:58.660Z] Check the top-level render call using <span>. See https://fb.me/react-warning-keys for more information.
[task 2019-05-10T14:40:58.661Z] in Unknown
[task 2019-05-10T14:40:58.661Z] Warning: Failed prop type: MessageIcon: prop type onRewindClick is invalid; it must be a function, usually from the prop-types package, but received undefined.
[task 2019-05-10T14:40:58.661Z] in MessageIcon
[task 2019-05-10T14:40:58.661Z] error Command failed with exit code 1.
[task 2019-05-10T14:40:58.661Z]
[task 2019-05-10T14:40:58.662Z] [devtools-node-test-runner] Parse errors from the test logs
[task 2019-05-10T14:40:58.662Z] TEST-UNEXPECTED-FAIL | mocha | webconsole | TypeError: dispatch is not a function
[taskcluster 2019-05-10 14:40:59.323Z] === Task Finished ===
[taskcluster 2019-05-10 14:40:59.324Z] Unsuccessful task run with exit code: 1 completed in 335.109 seconds

Flags: needinfo?(jdescottes)
(Assignee)

Comment 13

10 days ago

Looks like a recent changeset broke the webconsole test (still failing after the backout, but the suite is no longer tier 1). My revision was based on 65a693623, so something that landed after that. Will bisect.

Flags: needinfo?(jdescottes)

This was likely my work, though jest was passing for me locally before I merged:

https://phabricator.services.mozilla.com/rMCU804d239e671bc7572641c0c864fa7a147c338b3e

I'm checking it out quickly now.

(Assignee)

Updated

10 days ago
See Also: → 1550791
(Assignee)

Comment 15

10 days ago

This was regressed by Bug 1230194. I will skip the failing console mocha test here in order to land.

Comment 16

10 days ago
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/865ec5a708ba
Add proper logs for node-devtools test suite r=jlast

Comment 18

9 days ago
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/15d5a90bad2d
Add proper logs for node-devtools test suite r=jlast

Comment 19

9 days ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 9 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
(Assignee)

Updated

7 days ago
Flags: needinfo?(jdescottes)
Depends on: 1551608
(Assignee)

Updated

4 days ago
Depends on: 1552123
You need to log in before you can comment on or make changes to this bug.