Closed Bug 1496415 Opened Last year Closed Last year

USB devices sometimes not showing up on WebIDE

Categories

(DevTools :: about:debugging, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1493104

People

(Reporter: ladybenko, Unassigned)

References

Details

Attachments

(1 file)

With a USB device plugged in, sometimes it shows up on the sidebar in about:debugging, but not in WebIDE, and clicking the refresh button there doesn't help. After a few times of opening/closing WebIDE the USB device does appear. I don't see anything relevant in the Browser Console :(
Priority: -- → P2
I haven't really reproduced this bug yet, but sometimes adb.js fails to find the ADB files even though the addon is installed. You didn't happen to have

JavaScript error: resource://devtools/shared/base-loader.js -> resource://devtools/shared/adb/adb.js, line 104: NS_ERROR_ILLEGAL_VALUE: Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIProcess.init]

in your logs?
Flags: needinfo?(balbeza)
This is actually the "mirror" issue from Bug 1496108:
- in Bug 1496108, aboutdebugging expects that the ADB Addon status is correct when calling getAvailableAddons()
- in this bug, webide expects that ADB Addon will fire an "update" addon to notify that is it installed
Flags: needinfo?(balbeza)
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
One thing to mention is that these tricky interactions between WebIDE and aboutdebugging occur because all the webide modules are loaded in the same sandbox. So if aboutdebugging requires "devtools/client/webide/modules/addons" first, when WebIDE requires the module, it will get the same instance.
Priority: P2 → P1
Unassigning myself while I work on blocking bug 1493104 (I suspect I will end up closing this as duplicate after that).
Assignee: jdescottes → nobody
Status: ASSIGNED → NEW
Priority: P1 → P2
QA Contact: jdescottes
QA Contact: jdescottes
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1493104
No longer blocks: remote-debugging-ng-m1
You need to log in before you can comment on or make changes to this bug.