Remove the "notification" binding

RESOLVED FIXED in Firefox 65

Status

()

enhancement
P1
normal
RESOLVED FIXED
7 months ago
3 months ago

People

(Reporter: bgrins, Assigned: Paolo)

Tracking

(Blocks 1 bug)

unspecified
mozilla65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 months ago
+++ This bug was initially created as a clone of Bug #1471403 +++

We had some discussion about this at https://mozilla.logbot.info/fx-team/20181005#c15423019, so figured I'd get a bug on file for it. This would help make conversion to Fluent possible for notification.

This needs more investigation, but if the notifications are only ever created from within the notificationbox or at least a limited set of places it's possible we could build the entire DOM up directly under that node instead of slotting in child nodes into the [anonid="details"] element: https://searchfox.org/mozilla-central/rev/807a37c670c093b6e5201841a7c5315ba67ba8d5/toolkit/content/widgets/notification.xml#397.

We could do that either with a Custom Element (which would allow us to translate the properties/methods as in https://github.com/bgrins/xbl-analysis/blob/gh-pages/elements/generated/Notification.js), or move all the logic up into notificationbox.

Updated

6 months ago
QA Contact: gwimberly
(Assignee)

Updated

5 months ago
Summary: Investigate how to remove XBL for <notification> → Remove the "notification" binding
(Assignee)

Updated

5 months ago
Assignee: nobody → paolo.mozmail
Status: NEW → ASSIGNED
Priority: P5 → P1
(Assignee)

Comment 2

5 months ago
We may still have to update tests or production code that customizes the notifications, running a tryserver build here:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=d5d54ed862b50078e43382df9244f0af3ed7fc93
(Reporter)

Comment 5

5 months ago
Heads up that more notification changes are incoming (this is follow on to the work at bug 1471403). This is a Custom Element conversion so that part should work straight away, but a number of tests are needing to be updated (things that dig into anon content, some property accesses switching to attribute lookups, etc). See https://phabricator.services.mozilla.com/D11650.
Flags: needinfo?(jorgk)

Comment 6

5 months ago
Apparently we've already forked the binding and will de-XBL it later. Magnus, is anything required here?
Flags: needinfo?(jorgk) → needinfo?(mkmelin+mozilla)
(Reporter)

Comment 7

5 months ago
You'll probably need to rename the XBL'ed element from <notification> to something else so that you don't end up with both XBL and a Custom Element attached to it after this bug lands.

Comment 8

5 months ago
Pushed by paolo.mozmail@amadzone.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/91320b1c87ce
Remove the "notification" binding. r=bgrins

Updated

5 months ago
Depends on: 1507245
(Reporter)

Updated

5 months ago
Duplicate of this bug: 1450812

Comment 10

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/91320b1c87ce
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Flags: needinfo?(mkmelin+mozilla)
Depends on: 1519095
You need to log in before you can comment on or make changes to this bug.