Several custom form routes are not resolved, leading to 404 page not found, including Trademark Usage Requests

RESOLVED FIXED

Status

()

RESOLVED FIXED
6 months ago
5 months ago

People

(Reporter: kohei, Assigned: dkl)

Tracking

({regression})

Production
regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

There is a link to the Trademark Usage Requests under the mozilla.org (actually Marketing) product:

https://bugzilla.mozilla.org/page.cgi?id=custom_forms.html

The route is defined here, but the page is currently a 404 not found. I guess it’s a regression from Mojo migration.

https://github.com/mozilla-bteam/bmo/blob/master/extensions/BMO/Extension.pm#L2744-L2745
Flags: needinfo?(dylan)
https://bugzilla.mozilla.org/enter_bug.cgi?product=Marketing&format=trademark is working.

The dev mode Mojo 404 page shows the following stash:

```
{
  "REWRITE_trademark" => "form.trademark",
  "action" => "enter_bug_cgi",
  "cleanup_guard" => bless( [
    0,
    sub { "DUMMY" }
  ], 'Scope::Guard' ),
  "controller" => "cgi",
  "format" => "trademark",
  "product" => "Marketing"
}
```
(Assignee)

Comment 2

5 months ago
This seems to be working for me now.  Must have gotten fixed in the meantime. Please try it again and if it works then close this bug.
Flags: needinfo?(dylan) → needinfo?(kohei.yoshino)
Still broken for me. I forgot to provide the actual URL here? It’s https://bugzilla.mozilla.org/form.trademark
Flags: needinfo?(kohei.yoshino)
There are also broken:

https://bugzilla.mozilla.org/form.presentation
https://bugzilla.mozilla.org/form.recoverykey
Summary: Trademark Usage Requests: page not found → Several custom form routes are not resolved, leading to 404 page not found, including Trademark Usage Requests
(Assignee)

Updated

5 months ago
Assignee: nobody → dkl
Status: NEW → ASSIGNED
(Assignee)

Comment 5

5 months ago
Posted file GitHub Pull Request
Merged to master.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.