DNS: lookup failures after dialup

VERIFIED DUPLICATE of bug 151683

Status

()

Core
Networking
--
major
VERIFIED DUPLICATE of bug 151683
16 years ago
15 years ago

People

(Reporter: Martin Bayer, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529
BuildID:    2002052918

When starting mozilla-1.0 after a new dialup connection was set up, and no other
network clients (including other browsers) are uses, Mozilla will fail to
connect to almost any host, claiming (popup window) "host could not be found".
After sending a ping to that host (or using an other browser for it), Mozilla
will proceed normaly for that host. Strange enough, the _first_ connection will
mostly work. Thus, if you start at, say, google, everything will be fine. But
then you will be unable to follow the links.

Reproducible: Sometimes
Steps to Reproduce:
1. Start a new dialup connection, don't have other clients running
2. Lunch mozilla
3. Conect to a host (www.google.com)
4. Try to follow a link pointing to another domain

Actual Results:  Mozilla claims "Host could not be found".

Expected Results:  Lookup host correctly and connect.

Comment 1

16 years ago
Are you saying that a mozilla loookup works only after doing a lookup to the
same host with a different utility?
Summary: Stange DNS lookup failures → DNS: lookup failures after dialup
(Reporter)

Comment 2

16 years ago
Yes, this was what I thought when first running across this problem. The
"strange" thing in it was, that some hosts worked with Mozilla on the first
try and some not.
I've a direct dialup connection to the internet (no proxies) and tried any
of the HTTP options (protocoll 1.0/1.1, persistent connections ASO), but
without any effect on the DNS lookup failures.
I then played with the cookie options and could reproduce the lookup failure
several times for the site http://lang.openoffice.org/de/ on the condition
that the cookie policy was set to "the originating site only" and a new dialup
connection was set up. Mozilla would not fail to connect if it was
then restarted before trying again.
Thus, all I can say is, unfortunately, sometimes it works and sometimes not
(and this means that maybe the cookies don't break it).
we have tons of bugs for not seeing a changed DNS, but I can't find any right now
URL: any
Whiteboard: DUPME

Comment 4

16 years ago
I'm hoping to clean this up next week...

Comment 5

16 years ago
Bug 151683?
Bug 64857?

pi

Comment 6

16 years ago
yes.. resolving as dup of bug 151683, which was opened after some still saw
problems after bug 117628 -> bug 64857 were fixed. Dup'ing the "wrong way"
numerically since bug 151683 is mentioned in bug 117628.

*** This bug has been marked as a duplicate of 151683 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
VERIFIED/dupe
R.K.Aa: Actually you duped this the right way :)

I made the "master" duplicate bug 166479, and bug 151683 points to it now. Peter
created bug 151683 out of bug 117628 at my request, which I appreciate, but this
problem is really confusing and bug 166479 is where the most useful information
is located.

Thanks for helping with this.
Status: RESOLVED → VERIFIED
Whiteboard: DUPME
You need to log in before you can comment on or make changes to this bug.