Closed Bug 1497452 Opened 2 years ago Closed 2 years ago

[remote-dbg-next] UX: about:devtools-toolbox should not navigate to about:blank when the target is destroyed

Categories

(DevTools :: about:debugging, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1505368

People

(Reporter: jdescottes, Unassigned)

References

Details

STRs:
- enable new about:debugging
- connect a USB device with a tab open
- connect to the device on about:debugging, select it, inspect the tab
- wait until the opened toolbox is functional
- close the tab on the device

=> about:devtools-toolbox navigates to about:blank

Solution to be defined, but probably something like showing a "tab closed/target connection lost" message on the toolbox.
Priority: P3 → P2
This will also involve UX.
Summary: [remote-dbg-next] about:devtools-toolbox should not navigate to about:blank when the target is destroyed → [remote-dbg-next] UX: about:devtools-toolbox should not navigate to about:blank when the target is destroyed
Blocks: 1505368
Blocks: 1501640
No longer blocks: 1505368

This is being fixed in Bug 1505368

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1505368
No longer blocks: remote-debugging-ng-m2
You need to log in before you can comment on or make changes to this bug.