Better default fonts for Hebrew

RESOLVED FIXED in Future

Status

defect
P2
normal
RESOLVED FIXED
17 years ago
9 years ago

People

(Reporter: smontagu, Assigned: smontagu)

Tracking

({intl})

Dependency tree / graph
Bug Flags:
blocking1.4b -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt3], )

Attachments

(4 attachments, 3 obsolete attachments)

Assignee

Description

17 years ago
One of the commonest reactions to Netscape 7 and Mozilla from Hebrew users is
that the fonts are ugly.

http://groups.google.com/groups?selm=adm5uc%24hu41%40ripley.netscape.com
http://bugzilla.mozilla.org/show_bug.cgi?id=95227#c20
http://www.thenet.co.il/ts.cgi?tsscript=item&path=64&id=234940

I'd better translate the crucial sentence from that last one: "The Hebrew fonts
are unbearable, unless you like ornate, unreadable Talmudic fonts."

For Windows, I suggest at least changing to Narkisim for serif and Tahoma for
sans-serif, which I believe are widely available. I don't have any good
suggestions for the other families, or for the Mac.
Assignee

Comment 1

17 years ago
There seems to be some other bugginess with the current behaviour: the fonts
used by default to render a given language are not necessarily the same as the
fonts that appear when first going into the Preferences, so sometimes if I open
a Hebrew site with a new profile, go into the font preferences and press OK
without changing any setting, the displayed font changes. I have also seen the
same behaviour with Thai.

bug 61883 comment 24 seems to be talking about this issue.

Comment 2

17 years ago
For Mac OS, two good choices would be Raanana for serif, and Arial Hebrew for 
sans serif.

However, on many versions of mac and windows, anti-aliasing is not very good 
(and it is off by default), making the Hebrew serif fonts not very readble.

So IMO, the best would be to default to a sans-serif font for Hebrew and not a 
serif font.
OS: Windows 2000 → All
Hardware: PC → All

Comment 3

17 years ago
Notice that on OSX, setting Hebrew fonts via the prefrences does not have any 
affect.
See bug 110655
Depends on: 110655

Comment 4

17 years ago
For default serif vs. sans-serif issue, see also bug 95227

Updated

17 years ago
Depends on: 95227
Assignee

Comment 5

17 years ago
Posted patch Patch v.1 (obsolete) — Splinter Review
I have selected FrankRuehl and Tahoma as defaults for Windows, based on bug
134442 comment 2.

Comment 6

17 years ago
The screen shot in bug 134442 comment 2 is strange- since the fonts actually
shown there are arial, tahoma and times new roman. I am attaching screen shots
of the actual fonts

Comment 8

17 years ago
IMO, Tahoma is a bad choice as a default font for Hebrew, since it is larger
then other hebrew fonts at the same size (see in the above screen shot), and
thuse it can brake Visual Hebrew pages (which where designed with a smaller font
in mind). Frankruehl has the opposite problem: it is somewhat smaller then other
Hebrew fonts in the same size, making small text difficult to read.
IMO, we should go for Arial and Narkisim as the Hebrew windows default fonts.

Comment 9

17 years ago
Should I open another bug for OSX on the fact that does not use proper default
fonts for Hebrew? (other then bug 110655) It seems to be attempting to use the
system font, and when that fails (since lucida grande on OSX does not have
hebrew cmap), it uses the first font with Hebrew glyphs/cmap that it finds.
Assignee

Comment 10

17 years ago
Attachment #86891 - Attachment is obsolete: true
Assignee

Comment 11

17 years ago
Yes, please file a separate bug on the default fonts in OSX. I don't really
know, but maybe OSX has a problem with the font names in the Mac prefs file
being in Hebrew?
Keywords: nsbeta1
Do you want to use a list of fonts like other languages do? So if the primary 
font isn't there, other fonts will be used?

Comment 13

17 years ago
my comment #9 is now filed as bug 153296
Assignee

Comment 14

17 years ago
I don't think a font list will help much for Hebrew (at least on Windows). The
fonts in the patch are all available on every Windows installation that has
Hebrew fonts at all.

Shosh, what about Macs? Would a list be useful (maybe with Hebrew and English
names)?

Comment 15

17 years ago
please get r= and sr= and land into trunk.
Once that happen, we ask adt to approve it. 

This is a nice safe polish work. It won't impact English or other languages at
all and give Hebrew users a much better experience.
[adt3] because hebrew is not of the target market for adt now. 
Keywords: nsbeta1intl, nsbeta1+
Whiteboard: [adt3]

Comment 16

17 years ago
All system 9 Macs I have seen with Hebrew (language kit or Yeda Hebrew) have
Raanana Hebrew and Arial Hebrew (which is tottaly diffrent then Arial). On
system X, Hebrew support is expected to come officialy around Sept. 2002, so I
am not sure yet what Hebrew fonts it will include. Current OSX systems with
Hebrew  (Hebrew unicode keyboard hack, seen at the download page of
http://www.xredlex.com ) use the Hebrew fonts from Classic. It should be also
able to use Windows TTF fonts (but I was uanble to test this yet due to bug 110655).
A list should be more flexible, right? If so, that is the ay we need to go (with
raanan for serif and arial Hebrew for sans serif), to make sure that we do not
brake too much when apple will realese the 10.2 with Hebrew support.
Depends on: 153296
No longer depends on: 110655
QA Contact: sairuh → ruixu

Updated

17 years ago
QA Contact: ruixu → ylong

Comment 17

17 years ago
I am sure I have seen something like this in another bug here in bugzilla, but I
am unable to locate it:
Mozilla 1.1 beta, on mac os 9.2.1 from yeda (clean system):
the first time you go a hebrew page, the hebrew shows question marks. going into
the prefrences, changing the font thten hanging it back to the original- the
hebrew displays properly.
Now, what bug was it? it must be fixed before this is...
Assignee

Comment 18

17 years ago
*** Bug 183675 has been marked as a duplicate of this bug. ***

Comment 19

17 years ago
Note: for winprefs, you can add a fallback font.name-list. This way, you can
confidently pick the primary font.name as a really nice looking font (even if
rare). And then, dump in the name-list the other commonly installed fonts in
order of beauty. GfxWin will try the font.name first, if it is not installed, it
will continue with font.name-list in the same way as a CSS font-family list
order.

Updated

17 years ago
Depends on: 110655

Updated

17 years ago
Blocks: 190352

Comment 20

16 years ago
Please add "polish" to the keywords. This bug does require only a small change
(a patch is available) for a noticeable improvement in the user interface.

Prog.
Flags: blocking1.4b?
Assignee

Comment 21

16 years ago
Attachment #88508 - Attachment is obsolete: true
Assignee

Updated

16 years ago
Attachment #121310 - Flags: superreview?(roc+moz)
Attachment #121310 - Flags: review?(mkaply)

Comment 22

16 years ago
Comment on attachment 121310 [details] [diff] [review]
Patch with font lists

The bug is marked as OS=All/Platform=All but the patch only covers Windows (but
not OS/2 - why?) and Mac.
What about Linux/Solaris/AIX etc. ?!

Updated

16 years ago
Attachment #121310 - Flags: review?(mkaply) → review+
we don't need an OS/2 patch.
Assignee

Comment 24

16 years ago
Default Hebrew fonts on Linux are ugly too, but, at least in my experience, the
only way to get better ones is to download and install them yourself. Changing
the default prefs doesn't help because there is nothing much to choose from.

Comment 25

16 years ago
Simon Montagu wrote:
> Default Hebrew fonts on Linux are ugly too, but, at least in my experience, 
> the only way to get better ones is to download and install them yourself.

Yeah, but that is a Linux-only problem. On Solaris and other Unices the OS
usually provides useable hebrew fonts... IMHO we should try to cover that issue
somehow...
Assignee

Comment 26

16 years ago
OK, two questions. Which fonts does Mozilla use by default on those Unices? Are
there other fonts normally available which are better? I want to know that
there's a problem before we try to fix it. :-)
Assignee

Updated

16 years ago
Attachment #121310 - Flags: superreview?(roc+moz) → superreview?(rbs)

Comment 27

16 years ago
Simon Montagu wrote:
> OK, two questions. Which fonts does Mozilla use by default on those Unices?

On those platforms which have CDE there are the "dt-interface system-*" aliases
which map to the "font-of-choice" for that locale/OS (hebrew would be
"dt-interface system-iso8859-8").
See bug 202921 comment #2 ...

> Are there other fonts normally available which are better? I want to know that
> there's a problem before we try to fix it. :-)

Well, as I said on IRC - the best idea is to try to use the "dt-interface
system-*" fonts if available since they represent what the OS vendor prefers for
it's flavour of Unix.
I am working on that right now in bug 202921 ...
Assignee

Comment 28

16 years ago
So if you are working on a generic solution for the Unix default fonts in bug
202921, you have no objection to a solution being checked in for other platforms
in this bug, am I right?

Comment 29

16 years ago
Simon Montagu wrote:
> So if you are working on a generic solution for the Unix default fonts in bug
> 202921, you have no objection to a solution being checked in for other 
> platforms in this bug, am I right?

Erm... no problem from my side... :) I was just curious if you are planning to
the fix issue for Unix within this bug, too...

Comment 30

16 years ago
I totally agree with comment 2, Hebrew fonts should be set by default to Sans
Serif - on any platform. It is simply a matter of legibility.

Please don't make this a Windows-only feature.

Prog.
Assignee

Comment 31

16 years ago
The serif/sans-serif issue is covered elsewhere. I'm certainly not trying to
make this a "windows-only" issue, but the current windows defaults for Hebrew
are doubly terrible, since they are just copied from the Western defaults.
Comment on attachment 121310 [details] [diff] [review]
Patch with font lists

sr=jag on the Windows part of the patch.
Attachment #121310 - Flags: superreview?(rbs) → superreview+
jag, why are you only sr'ing the Windows part of the patch? sr is not supposed
to be platform specific review.
Assignee

Comment 34

16 years ago
jag and I talked about it on IRC and agreed to postpone the Mac part until I
could test it and/or until the Mac-specific blockers were resolved.

Updated

16 years ago
Flags: blocking1.4b? → blocking1.4b-

Comment 35

16 years ago
If you are waiting for bug #110655 to be fixed before you work on this one- it
will take a while, as no one is activly working on it (and the users are just
giving up gekco browsers and move to Safari)

Comment 36

16 years ago
> The serif/sans-serif issue is covered elsewhere.

The only somewhat-related bugs that I could find are Bug 61883 - "Smarter
default prefs for the 5 basic CSS fonts" and Bug 95227 - "Unable to set
different default font type (serif vs sans serif) for different languages".
The former doesn't talk about Hebrew and the latter merely discusses the
limitation of only being able to set a single global pref for Serif/Sans Serif.


Most people agree that sans-serif fonts are easier to read on the screen, while
serif fonts are easier to read on paper. I think that it's also obvious from
the attached screenshot that the sans-serif font (Arial) is far more legible.
This is probably why other browsers (such as IE) also use sans-serif fonts as
the default proportional font.

Due to bug 95227, changing the default proportional font to sans-serif would
apply to all languages, but this is actually a good thing as it would fix an
old problem that doesn't only affect Hebrew.

For the sceenshot I used http://www.haayal.co.il/story_1426 under Mozilla
1.4a/20030321/WinXP-SP1 (with ClearType set).

Prog.
Priority: -- → P2
Target Milestone: --- → Future

Comment 37

15 years ago
Comment on attachment 121310 [details] [diff] [review]
Patch with font lists

Simon, I know it's a bit late to ask this now, but was there any good reason to
replace Courier New with Fixed Miriam Transparent?

IMHO, the former was a better choice. Details here:
http://mozilla.org.il/board/viewtopic.php?p=3684#3684

Prog.

Updated

15 years ago
Blocks: 240501
Assignee

Comment 38

15 years ago
Since none of the original defaults were consciously chosen for Hebrew, I
replaced all of them with specifically Hebrew fonts. Your reasons for preferring
Courier New are all good, but I would like to confirm that the version of
Courier New on older systems even has Hebrew glyphs.

Comment 39

15 years ago
(In reply to comment #24)
> Default Hebrew fonts on Linux are ugly too, but, at least in my experience, the
> only way to get better ones is to download and install them yourself. Changing
> the default prefs doesn't help because there is nothing much to choose from.

Modern Linux distros come with Culmus fonts (http://culmus.sf.net), however,
they are avalible by default only the XFT builds of Mozilla
Assignee

Comment 40

15 years ago
(In reply to comment #39)

> Modern Linux distros come with Culmus fonts (http://culmus.sf.net), however,
> they are avalible by default only the XFT builds of Mozilla

My understanding is that the default font settings in Xft builds come from
fontconfig. Is that right, Jungshik? Does fontconfig include language-specific
defaults?

Comment 41

15 years ago
(In reply to comment #40)

> My understanding is that the default font settings in Xft builds come from
> fontconfig. Is that right, Jungshik? Does fontconfig include language-specific
> defaults?

No, it does not come directly from fontconfig. Xft+gtk2 build picks up the
default font from gtk2 configuration file (e.g. /etc/gtk-2.0). We could have
added an Xft-specific default font list (a la AIX font list) but blizzard wanted
Mozilla to honor the system-wide default font configuration for gtk(2). 
 

Comment 42

15 years ago
(In reply to comment #38)
> Your reasons for preferring Courier New are all good, but I would 
> like to confirm that the version of Courier New on older systems 
> even has Hebrew glyphs.

It does. See attachment.

Prog.

Comment 43

15 years ago
A crazy idea: how about changing the default *Serif* font to Arial? Now, I know
that Arial is a *Sans Serif* font, but when it comes to Hebrew pages, the
legibility improvement such a change can bring may be significant.

Until Bug 95227 is solved, this is the only way to make the default Hebrew font
more legible, after all, it is very unlikely that Mozilla will switch to Sans
Serif fonts for all other languages (at least not until Bug 244439 and Bug
244693 are fixed).

Prog.

Comment 45

15 years ago
To anyone who might want to voluntarily review this patch, please be patient
until further (and exciting!) information is posted later today.

Thanks,

Prog.

Comment 46

15 years ago
Comment on attachment 162101 [details] [diff] [review]
per comment 43

We've done a small "usability test" and displayed Mozilla default fonts for
Sans Serif and Serif to a group of users at hwzone.co.il forums (a major
Israeli techsite). Both fonts (Arial and Narkisim respectively) were sized
equally, and both included normal and bold versions.

The results are overwhelmingly in favor of the Sans Serif font Arial. 19:1, or
95%, whichever way you'd like to look at it. The comments to the discussion
echo this, as virtually all users judged Arial to be significantly more
legible. This shouldn't really surprise anyone, as Hebrew is very unforgiving
to Serif fonts displayed on low resolution devices such as computer screens.

URL of the HWzone poll:
http://www.hwzone.co.il/community/index.php?topic=89493.0

Prog.
Attachment #162101 - Flags: superreview?(mkaply)
Attachment #162101 - Flags: review?(smontagu)

Comment 47

15 years ago
(In reply to comment #46)
> (From update of attachment 162101 [details] [diff] [review])
> We've done a small "usability test" and displayed Mozilla default fonts for
> Sans Serif and Serif to a group of users at hwzone.co.il forums (a major
> Israeli techsite). Both fonts (Arial and Narkisim respectively) were sized
> equally, and both included normal and bold versions.

I am not sure I agree with your test there.
1) You used a very small size (10 and not the standard 12).
2) Narkisim is not a very good screen font. However, there are better serif
fonts out there (like David). We don't have to jump from serif to sans-serif)
3) If we change the default from Seif to Sans-Serif, we will be affecting *all*
mozilla users (even non-Hebrew) due to bug 95227

Comment 48

15 years ago
(In reply to comment #43)
> A crazy idea: how about changing the default *Serif* font to Arial? Now, I know
> that Arial is a *Sans Serif* font, but when it comes to Hebrew pages, the
> legibility improvement such a change can bring may be significant.

That will brake web pages which use CSS to set font (not calling a font face).
For example, if someone defines the headers as "serif" and body as "sans-serif"
via CSS, having are serif font be actually sans-serif will brake the web page.
Assignee

Comment 49

15 years ago
(In reply to comment #46)
> (From update of attachment 162101 [details] [diff] [review])
> We've done a small "usability test" and displayed Mozilla default fonts for
> Sans Serif and Serif to a group of users at hwzone.co.il forums (a major
> Israeli techsite). Both fonts (Arial and Narkisim respectively) were sized
> equally, and both included normal and bold versions.

Using the same small size for serif and sans serif slants the test in favour of
the sans-serif fonts. The default font size is 16.
Assignee

Comment 50

15 years ago
Comment on attachment 162101 [details] [diff] [review]
per comment 43

r- for the reasons in the last 3 comments
Attachment #162101 - Flags: review?(smontagu) → review-

Comment 51

15 years ago
Comment on attachment 162101 [details] [diff] [review]
per comment 43

(In reply to Shoshannah Forbes, comment #47 and #48)
> I am not sure I agree with your test there.
> 1) You used a very small size (10 and not the standard 12).

Websites use various font sizes, but only small fonts pose the legibility
issues that this test was meant to uncover.

> 2) Narkisim is not a very good screen font. However, there are better serif
> fonts out there (like David). We don't have to jump from serif to sans-serif)

When it comes to small sized fonts and Hebrew, all Serif fonts are in the same
ballpark - they all suck. 10p Hebrew text clearly shows that Narkisim and David
are practically illegible compared to Arial. See here:
http://oren.gomen.org/mozilla/font_comparison3.png

> 3) If we change the default from Seif to Sans-Serif, we will be affecting *all*
> mozilla users (even non-Hebrew) due to bug 95227

That's not what this patch does. It only changes the Hebrew case.

> That will brake web pages which use CSS to set font (not calling a font face).
> For example, if someone defines the headers as "serif" and body as "sans-serif"
> via CSS, having are serif font be actually sans-serif will brake the web page.

As this poll suggests, 95% of our potential users believe that this is a small
price to pay in favor of vastly better legibility. The few web-builders who may
want to force Serif fonts on their users can work-around this new limitation by
specifying their preferred Serif fonts, rather than just the family. I mean, if
we think it's ok to expect web-builders to jump through hoops when they want to
show "glow" in Gecko, why shouldn’t we expect them to workaround something that
makes Mozilla easier on the eyes of 95% of our target Hebrew users?

(In reply to Simon Montagu, comment #49)
> Using the same small size for serif and sans serif slants the test in favour of
> the sans-serif fonts. The default font size is 16.

This test attempts to deal with Mozilla's legibility issues with Hebrew texts.
These mostly kick in with small fonts. If you wish, I can get some input on
users' attitude toward larger Serif fonts, but I'd be very surprised if anyone
flips their vote. 16p Serif may be sufficiently legible, but it still looks
outdated and biblical. We've had plenty of such comments in the discussion
already, and I personally feel the same.

There's just too much to gain from this slight bending of the rules. Please
take this into account and reconsider the fate of this patch.

Prog.
Attachment #162101 - Flags: superreview?(mkaply)
Product: Browser → Seamonkey
Comment on attachment 162101 [details] [diff] [review]
per comment 43

Arial is now the default font on Windows (see bug 95227).
Attachment #162101 - Attachment is obsolete: true

Comment 53

15 years ago
So what does it take to wrap things up and close this bug? There's the Courier
New issue (comment #37 to comment #42). Anything else?

Prog.

Comment 54

13 years ago
Why has this patch not been checked in yet?

Comment 55

13 years ago
Umm, except for the Courier New thing. Definitely shouldn't change to Miriam.

Comment 56

12 years ago
From what I can tell:

http://lxr.mozilla.org/seamonkey/source/modules/libpref/src/init/all.js

this is all fixed except for the Courier New/Miriam issue. so if people agree with me, let's patch that, and if not, close this bug.

Comment 57

11 years ago
I cannot change the default Hebrew fonts on my Mandriva Cooker Firefox 2.0.0.11 setup. I heard from someone on Ubuntu and on Windows, that he could not change them either. Only assigning an explicit "font-family" on the CSS of the page has an effect of changing them.

This is bad. Is Hebrew font changing going to be fixed in Firefox 3.0.x?
QA Contact: amyy → prefs

Comment 58

9 years ago
Closing based on Comment 56 and nobody has complained about Fixed Miriam Transparent ever since this bug.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 59

9 years ago
But nobody has said Fixed Miriam Transparent is an acceptable choice, either.

I ask that this be reopened. Can't we just patch this and be done with it?
You need to log in before you can comment on or make changes to this bug.