Better default Hebrew & Arabic fonts on Mac OS X

RESOLVED FIXED in Future

Status

()

Core
Layout: Text
--
major
RESOLVED FIXED
16 years ago
9 years ago

People

(Reporter: Shoshannah Forbes, Assigned: Smokey Ardisson (offline for a while; not following bugs - do not email))

Tracking

Trunk
Future
PowerPC
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: see comment 11)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1a) Gecko/20020616
BuildID:    2002061603

(This bug is related to bug 149796 and bug 110655)
Mozilla is not using the proper default fonts to render Hebrew pages. It is
attempting to use the system font (Lucida Grande) which does not have Hebrew
cmap. So, Mozilla ends up using the first font it finds with Hebrew cmap and
Hebrew glyphs, leaving the user with no control on the actual font mozilla uses.
Depending on the user's system, the actual font used to render Hebrew pages can
be really bad- like a fantasy style bold italic font...

One workaround is to install lucida grande from OSX beta (which did have Hebrew
cmap). But since most users do not have access to it, this is not practicle.

When a users adds a "funny" Hebrew font to the system (to use in graphics titles
for example) Mozilla uses those fonts.

Reproducible: Always
Steps to Reproduce:
just go to any Hebrew page

Actual Results:  the font used is not related to the default Hebrew font settings

Expected Results:  should use proper default fonts
Assigning Mac Bidi problem to ftang
Assignee: mkaply → ftang
(Reporter)

Updated

16 years ago
Blocks: 149796
(Reporter)

Updated

16 years ago
Blocks: 154625

Comment 2

16 years ago
does MacOS X 10.1.5 support Hebrew locale? or not?
What is "THE propert Hebrew" font on MacOS X which all the users will have?
Assignee: ftang → nhotta
(Reporter)

Comment 3

16 years ago
I am not sure what do you mean by "hebrew local" in this context. osx has
hebrew, but as a unicode keyboard. this is a the case both with 10.1.5 (which
oes not have official hebrew supoort) and 10.2 (which does hve official hebrew
support).
As for fonts, if you go to fonts from classic (that evryone will have) you have
raanana, corsiva and arial hebrew.
lucida grande has hebrew only in 10.2 and the beta of 10.0. in 10.0-10.1.5 it
does not have hebrew cmap (althugh it contains hebrew glyphs)

Comment 4

16 years ago
Frank, we use ATSUI to draw Hebrew. Do we set a user's pref font to ATSUI?
http://lxr.mozilla.org/seamonkey/source/gfx/src/mac/nsUnicodeRenderingToolkit.cpp#149
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.2alpha

Updated

15 years ago
Target Milestone: mozilla1.2alpha → ---

Comment 5

15 years ago
Another problem even on OS X 10.2, both Mozilla, Mozilla Firebird and Camino will not use Arial - 
and always use Lucida Grande - which looks rather ugly on titles.

I tried Mozilla 1.2.1, 1.3, 1.4, Mozilla Firebird from 2 days ago, Camino 0.6 and 0.7 - and it will 
not work. You set Arial font (I took this font from Windows and it works finde in other applications) 
and they use Lucida Grande.
(Reporter)

Updated

14 years ago
Blocks: 103669
Two things:
 (1) Working now on bug 120401, patch is nearly ready, and it should also solve
this bug, I need to decide which fonts will be the default (Serif, sans-serif
and Monospace), you are welcome to choose.
 (2) Since OS X 10.2, Mozilla uses Lucida Grande which does contain Hebrew cmap
(since this version of the OS).
Adding dependence for bug 120401, in fact, this is a duplicate.
Depends on: 120401

Comment 8

14 years ago
(In reply to comment #6)
>  (1) Working now on bug 120401, patch is nearly ready, and it should also
solve this bug, 

Way to go!

> I need to decide which fonts will be the default (Serif, sans-serif
> and Monospace), you are welcome to choose.

You don't have much choice actually. By default, Mozilla uses Serif fonts for
Proportional fonts (due to Bug 95227, this is regardless of language. Monospace
fonts should be, well... Monospace. The only thing open for discussion is which
fonts should used, not which types.

> Adding dependence for bug 120401, in fact, this is a duplicate.

You're now assigned to both bugs. Feel free to close one of them as a dupe.

Prog.
Assignee: nhottanscp → romano_a
Status: ASSIGNED → NEW
(In reply to comment #8)
> (In reply to comment #6)
> > I need to decide which fonts will be the default (Serif, sans-serif
> > and Monospace), you are welcome to choose.
> 
> You don't have much choice actually. By default, Mozilla uses Serif fonts for
> Proportional fonts (due to Bug 95227, this is regardless of language. Monospace
> fonts should be, well... Monospace. The only thing open for discussion is which
> fonts should used, not which types.
> 
Heh, I talked about the fonts for each type.

> > Adding dependence for bug 120401, in fact, this is a duplicate.
> 
> You're now assigned to both bugs. Feel free to close one of them as a dupe.
> 
Thanks.

OK, I'm not marking this as a duplicate because I gues we want to use Arial 
Hebrew and Ranana instead of ugly Lucida Grande (which will be the default 
font after landing the patch for bug 120401). We are not able to use these 
fonts unless bug 246527 will be fixed.
Status: NEW → ASSIGNED
Depends on: 246527
The patch for bug 120401 has been checked in. Default serif/sans-serif is Lucida
Grande, for now (we will be able to fix it, after fixing bug 246527).
Summary: Mozilla does not use correct default fonts for Hebrew on OSX → Better default Hebrew & Arabic fonts on Mac OS X
Whiteboard: see comment 11
Target Milestone: --- → Future
Assignee: bugs.mano → nobody
Status: ASSIGNED → NEW
QA Contact: zach → layout.bidi
I'll fix this as part of bug 299222.

Are Arial Hebrew and Raanana still the preferred Hebrew fonts?
Assignee: nobody → alqahira
Depends on: 299222
Arial Hebrew and Raanana look good to me.
FIXED on trunk by checkin for bug 299222.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

9 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: layout.bidi → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.