After FxA account password reset, send tab is working one sided between desktop and Android

VERIFIED FIXED in Firefox 64

Status

()

defect
P1
normal
VERIFIED FIXED
7 months ago
7 months ago

People

(Reporter: kkumari, Assigned: eoger)

Tracking

unspecified
Firefox 64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 verified)

Details

Attachments

(6 attachments, 1 obsolete attachment)

Reporter

Description

7 months ago
Prerequisite: About:sync addon is installed on new Fx profile

STR: 
1. Sign in to sync on Win 10 desktop with new sync account and new Fx profile
   Version 	64.0a1
   Build ID 	20181010100123
   User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0
2. Sign in to sync on Android mobile
   Nexus 5
   Android version  5.1.1
   Firefox Version  64.0a1 (2018-10-10)
3. Sign in to sync on iPad Air 2
   iOS 12.0.1
   Firefox Beta 
   Version 14.o(12307)

4. Verify send/receive tabs from all device working fine (other than known bug 1484059). 
5. Verify FxA device list, about:sync client collection and send tab list are showing all devices as expected.
   Observed: No issue so far.
6. Change FxA password on iPad
7. Desktop and android devices are disconnected from sync.
8. Sign back to sync on desktop and Android with new password
9. Send tab from Android to desktop. Tab is received on desktop.
10.Send tab from desktop to Android 

Observed: Tab is not received on Android 
In browser console on desktop:
Could not find associated FxA device for Nightly on Nexus 5


Please see also bug 1496846
Reporter

Updated

7 months ago
Flags: needinfo?(eoger)
Reporter

Comment 1

7 months ago
This bug is reproducible even if I change password on desktop. So it's device registration issue after password change (not due password change on iOs device).

STR: 
1. Sign in to Desktop (win 10), iPad and android
2. Verify send/receive tan working fine across all three devices.
3. Change password on Desktop.
4. sign back  to sync on Android and iPad with new password.
5. Manually sync all devices.
6. Send tab from desktop to iPad and Android

Observed: iPad  received the tab but  Android didn't. 
Browser console shows "Could not find associated FxA device for Nightly on Nexus 5"

7. Send tab from android to desktop and iPad

Observed: Desktop received the tab from android but iPad didn't

After ~3 minutes I get message on android and iPad to sign in to sync to reconnect. 

8. Reconnect to sync on Android and iPad.
9. Android received all the pending tabs from desktop and iPad 
10. Send tab from desktop to android 

Still cant send tab from desktop to android. Tab is  getting send from android to desktop and iPad.
Reporter

Comment 2

7 months ago
After password reset issue is irrespective to FxA command. I could reproduce this issue without FxA command as well. In fact It was worst with  FxA command disabled. After password reset in step #3 (Comment 1)follow step #5-6.
No tab is sent to android and iPad

Browser console says "Could not find associated FxA device for Firefox Beta on Softvision’s iPad browser-sync.js:332:9
Could not find associated FxA device for Nightly on Nexus 5"

Please note:
Tab is sent from Android to desktop
Tab is sent from iPad to Android but not from Android to iPad as iPad is not in send tab list on Android
Can't  send tab from iPad to Desktop as desktop is not in send tab list on iPad
Assignee

Comment 3

7 months ago
Thank you Kanchan, I've been able to reproduce the problem.
Here are some things that we need to fix to make the change password experience a pleasant one on Android:

- No handler defined for FxA Push command fxaccounts:password_changed.
- Reconnect button only shows after 2 manual sync.
- Device registration version not cleared after reconnect.
- No auto-syncing after reconnect (therefore no device registration).

It seems that if the password change is initiated on Android, we also have:
- No auto-syncing after reconnect (therefore no device registration).
However, the device registration version seemed to have been cleared, because of the next sync the device appeared to have registered.
Assignee

Updated

7 months ago
Flags: needinfo?(eoger)
Assignee

Updated

7 months ago
Depends on: 1385454
Assignee

Updated

7 months ago
Duplicate of this bug: 1385454
Assignee

Updated

7 months ago
Assignee: nobody → eoger
Status: NEW → ASSIGNED
Priority: -- → P1
Assignee

Comment 12

7 months ago
Comment on attachment 9016816 [details]
Bug 1497977 p3 - Drive the account to Separated state on token server error.

Grisha mind having a look? We're not sure if it's actually OK to go to separated after a token server error.
Attachment #9016816 - Flags: review?(gkruglov)
Duplicate of this bug: 1300736
Attachment #9016816 - Attachment is obsolete: true
Attachment #9016816 - Flags: review?(gkruglov)
Attachment #9016817 - Attachment description: Bug 1497977 p4 - Retry a device registration immediately after recovering from a unknown device error. → Bug 1497977 p3 - Retry a device registration immediately after recovering from a unknown device error.
Attachment #9016818 - Attachment description: Bug 1497977 p5 - Trigger an upload of our own client record after FxA device registration. → Bug 1497977 p4 - Trigger an upload of our own client record after FxA device registration.
Attachment #9016819 - Attachment description: Bug 1497977 p6 - Flag local client record for upload on fxa device id change. → Bug 1497977 p5 - Flag local client record for upload on fxa device id change.
Attachment #9016820 - Attachment description: Bug 1497977 p7 - Also send a collection_changed push notification when uploading our client record following an fxa device id change. → Bug 1497977 p6 - Also send a collection_changed push notification when uploading our client record following an fxa device id change.

Comment 14

7 months ago
Pushed by eoger@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3901ae585e3a
p1 - Renew the fxa device registration/client record on FxA account reconnection. r=nalexander
https://hg.mozilla.org/integration/autoland/rev/e720c16aa7c6
p2 - Handle fxaccounts:password_changed push messages. r=nalexander
https://hg.mozilla.org/integration/autoland/rev/5238702906f6
p3 - Retry a device registration immediately after recovering from a unknown device error. r=nalexander
https://hg.mozilla.org/integration/autoland/rev/ea10b0217cec
p4 - Trigger an upload of our own client record after FxA device registration. r=nalexander
https://hg.mozilla.org/integration/autoland/rev/60c949b40f46
p5 - Flag local client record for upload on fxa device id change. r=nalexander
https://hg.mozilla.org/integration/autoland/rev/3506efe6428a
p6 - Also send a collection_changed push notification when uploading our client record following an fxa device id change. r=nalexander
Reporter

Comment 16

7 months ago
I have verified this bug fix with desktop (the latest nightly Build ID 20181023100120), iOS beta 14 and Android. Send tab is working fine across all devices after password change.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.