Closed Bug 1300736 Opened 3 years ago Closed Last year

Changing FxA password causes device registration to be lost

Categories

(Firefox for Android :: Firefox Accounts, defect)

Unspecified
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1497977

People

(Reporter: pb, Unassigned)

References

Details

(Whiteboard: [fxa-waffle])

This is the Fennec peer to bug 1296328 and bug 1300297.

When a user changes their password in FxA, the server destroys the device record. This leaves the user with a signed-in Sync session that doesn't show up in their list of connected devices.

To reproduce:

1. On Fennec, sign in to Sync.
2. Confirm sign-in via email.
3. Click `Sync preferences`.
4. Click `Manage account`.
5. Next to `Password`, click `Change`.
6. Enter old and new passwords, then click `Change`.
7. Add the query param `forceDeviceList=1` to the URL.
8. Next to `Devices`, click `Show`.
9. Click `Refresh`.

At this point, the current device should show up in the list of devices but it doesn't.

To fix, clients must re-register the device (including the device id in the request) after handling the `fxaccounts:change_password` web-channel notification.
:eoger kindly gave me some advice on what an appropriate fix should look like, recording it here for my own benefit.

Registration should happen somewhere near here:

https://dxr.mozilla.org/mozilla-central/source/mobile/android/base/java/org/mozilla/gecko/AccountsHelper.java#186

Registration looks like this:

https://dxr.mozilla.org/mozilla-central/source/mobile/android/services/src/main/java/org/mozilla/gecko/fxa/sync/FxAccountSyncAdapter.java#541
See Also: → 1300740
Component: FxAccounts → Firefox Accounts
Product: Core → Firefox for Android
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1497977
You need to log in before you can comment on or make changes to this bug.