Closed Bug 1498188 Opened Last year Closed 3 months ago

Show graphically relative energy impacts of tabs

Categories

(Toolkit :: Performance Monitoring, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox64 --- wontfix
firefox70 --- fixed

People

(Reporter: florian, Assigned: fluks.github)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

This is implementing the blue bars in the energy impact column in the UX mockup (https://mozilla.invisionapp.com/share/SDOE65KGU2Z).
It's late to have this in 64, and Bryan agreed this isn't required for MVP, so I have no intent to uplift a patch for this to beta.

I could work on this bug because bug 1553782 isn't confirmed yet, so as far as I understand, I can't work fully on it before it is?

I looked at the mockup and the graphical bar doesn't seem to grow linearly based on energy impact, should it grow in some kind of steps? How about if energy impact is low, the bar would be 0-10% of the width of the element, 10-50% for medium and 50-100% for high? And the energy impact can be higher than 100%? In that case, then you need to find the highest energy impact and make it to be 100% wide and all the other high energy impacts in relation to the highest?

Hi Emilio, any chance you could have a quick look at the question asked in https://phabricator.services.mozilla.com/D35652#1084246 ? Thanks!

Flags: needinfo?(emilio)

So a reduced test-case for that is data:text/html,<div style="--x: 20; width: var(--x)%; height: 50px; background: green"></div>, which only works on Firefox.

I think this is a bug in Firefox. I don't know off the top of my head what the % text tokenizes to, but probably a combination of Number and that should return true in this function.

Flags: needinfo?(emilio)

https://github.com/servo/rust-cssparser/pull/251 is the fix to the CSS parser, https://github.com/w3c/csswg-drafts/issues/4088 is the spec issue, since we were implementing the spec to the letter.

Assignee: nobody → fluks.github

My attempt to land the patch with Lando failed because of other changes from bug 1561435 that have landed in the meantime. Any chance you could update the patch? Thanks and sorry for the inconvenience.

Flags: needinfo?(fluks.github)

I fixed the merge conflict, I hope it works now.

Flags: needinfo?(fluks.github)
Pushed by fqueze@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d1bfe8eb6e7c
Show graphically relative energy impacts of tabs. r=florian
Backout by shindli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4d7785621170
Backed out changeset d1bfe8eb6e7c for causing ES lint failure in /builds/worker/checkouts/gecko/toolkit/components/aboutperformance/content/aboutPerformance.js:487:21 CLOSED TREE
Pushed by fqueze@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e1778259f08c
Show graphically relative energy impacts of tabs. r=florian
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Depends on: 1565896
QA Whiteboard: [qa-70b-p2]
You need to log in before you can comment on or make changes to this bug.