Closed Bug 1498839 Opened Last year Closed Last year

copyUrlPopup context menu not shown for link in RSS feed message header (normal copyPopup context menu shown)

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 64.0

People

(Reporter: joachim.herb, Assigned: mkmelin)

References

Details

(Keywords: regression)

Attachments

(1 file)

In the current turn (64.0) the special context menu for URL is not working anymore in the header of RSS feed messages. Instead the "normal" context menu for copying, e.g. for copying the subject, is shown. In 63.0 (beta) it still works as before.

Steps to reproduce:
Select a message of an RSS feed.
Right click on the article URL in the header.
Normal context menu for copying is shown instead of the special copyUrlPopup 
defined at https://dxr.mozilla.org/comm-central/source/comm/mail/base/content/msgHdrPopup.inc#130
Status: NEW → UNCONFIRMED
Ever confirmed: false
Looks like a regression from the de-XBL work.

So correct would be to show: Copy link location, and not the "normal" context menu.
Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(arshdkhn1)
Assignee: nobody → mkmelin+mozilla
Blocks: 1489748
Flags: needinfo?(mkmelin+mozilla)
Keywords: regression
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(arshdkhn1)
Attachment #9017031 - Flags: review?(arshdkhn1)
Comment on attachment 9017031 [details] [diff] [review]
bug1498839_mailurlfield_context.patch

Review of attachment 9017031 [details] [diff] [review]:
-----------------------------------------------------------------

https://searchfox.org/comm-central/source/mail/base/content/mailWidgets.js#10 , why adding again?
I'm not. Different context.
Attachment #9017031 - Flags: review?(arshdkhn1) → review+
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/8539fb6b4605
fix context menu for link in RSS feed message header (normal copyPopup context menu instead of copyUrlPopup). r=arshad
Status: ASSIGNED → RESOLVED
Closed: Last year
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 64.0
You need to log in before you can comment on or make changes to this bug.