Closed Bug 1498916 Opened Last year Closed Last year

Amazon top search cannot be disabled despite "Add Search Engine" interface giving impression that it can be

Categories

(Firefox :: New Tab Page, enhancement)

64 Branch
enhancement
Not set

Tracking

()

RESOLVED INVALID
Tracking Status
firefox63 --- wontfix
firefox64 --- affected

People

(Reporter: ke5trel, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: uiwanted)

Attachments

(1 file)

Set browser.search.region = AU and restart the browser. Amazon top site appears as @amazon top search exactly as described in Bug 1483899 which was meant to be solved by Bug 1482629.
Bug 1482629 was about locale, and it seems like you're talking about region. What locale are you using when setting region to AU?
Locale is en-US. I tested some other regions:

Good: US, GB, RU, JP, CA, DE, FR, IT
Bad: AU, TR, KZ, BY, CN, RO

Note when switching between some regions, Amazon needs to be removed from top searches for bug to be evident.
Summary: Amazon still incorrectly appears as top search for certain region → Amazon incorrectly appears as top search for some regions
Do these appear with a pin icon next to the "@amazon"? Amazon is a default top site for those regions that changes to a search shortcut for en-US, but it should only be pinned in certain regions.

Also, what makes you say RU and CA is "good" while the others are "bad?"
Flags: needinfo?(ke5trel)
It turns out all regions are affected when @amazon is unpinned, it still appears as "@amazon" like Bug 1483899 describes. It's just easier to notice in regions where it is not pinned by default.

https://bug1483899.bmoattachments.org/attachment.cgi?id=9001637

Interestingly Twitter and Wikipedia both have top sites and top searches which can be switched between without issue, only Amazon is affected.
Flags: needinfo?(ke5trel)
This sounds like it's working as intended then. Only Google and Amazon are default pinned in some regions while any locale that has those default search engines will get a top site switched to a search shortcut.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → INVALID
What is the purpose of the Amazon entry under "Add Search Engine" then? It only pins/unpins and doesn't add/remove from top searches like Twitter and Wikipedia which have the expected behavior. Managing pinned state is already possible without this interface and it is confusing for top search to appear optional when it isn't. This is a regression for users who don't want Amazon as a top search and want to keep it as a top site like before. The "Add Search Engine" interface gives the impression that its intended purpose is to address this problem.
No longer blocks: 1482629
Status: RESOLVED → REOPENED
Keywords: regression
Resolution: INVALID → ---
Summary: Amazon incorrectly appears as top search for some regions → Amazon top search cannot be disabled despite "Add Search Engine" interface giving impression that it can be
Comparison of expected and actual behavior.
The "Add Search Engine" is to add a pinned search right now, so that's why amazon is an option to pin when it's not currently pinned.

uiwanted: Should "Add Search Engine" reflect an "organic search upgrade" of a top site to search shortcut and allow reverting it back to a plain top site?
Keywords: regressionuiwanted
Flags: needinfo?(abenson)
The "Add Search Engine" dialog should indicate whether or not that a shortcut is visible in the top sites list on new tab but you can't revert shortcut items back to "normal" top sites, unless you manually add a top site.
Flags: needinfo?(abenson)
I had a look at SearchShortcuts.jsm and it makes some sense now, certain organic top sites (Amazon, Baidu, Google and Yandex) are given special treatment and automatically converted to search shortcuts. Without knowing this the inconsistent behavior is mysterious.

Behavior that a user might expect:
1. All known search engines are automatically converted.
2. General-purpose search engines are converted (eg Google, Bing, DDG).
3. The editor controls which search engines are converted.

Manually adding a top site is a workaround but feels a bit clunky and non-intuitive, the user could easily assume it would be converted to a search shortcut as well.
We are closing this for now as the UX is working as intended
Status: REOPENED → RESOLVED
Closed: Last yearLast year
Resolution: --- → INVALID
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.