Closed Bug 1482629 Opened Last year Closed Last year

Amazon shown as a top search when it should be a plain top site for some locales

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 63
Iteration:
63.4 - Aug 20
Tracking Status
firefox62 --- verified
firefox63 --- verified

People

(Reporter: Mardak, Assigned: andreio)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image should not be @amazon
With the latest mac es-MX build 20180811103606 from https://download.mozilla.org/?product=firefox-nightly-latest-l10n-ssl&os=osx&lang=es-MX

Amazon is correctly not pinned but it still shows as an organic search. Amazon is not a search provider in the build, so it doesn't show up in the Add Search Engine.

The address bar correctly indicates there's no @amazon search keyword.

Services.search.getEngines().map(v => v.identifier)
Array(5) [ "google", "bing", "ddg", "mercadolibre-mx", "wikipedia-es" ]

I am running this from US if that matters:
browser.search.region;US
zh-CN build actually has @amazon pinned, but it does not work as amazondotcn is not intended to be a search as per bug 1482125
Depends on: 1482125
See Also: → 1482633
The fix here probably needs to check instead of search.getEngines()…engine.identifier.match(shortcut.searchIdentifier), check search.getDefaultEngines().…engine.wrappedJSObject._internalAliases.includes(shortcut.keyword)

This means we don't need a separate searchIdentifier property.
Assignee: nobody → andrei.br92
In my case @amazon search does exist and is not enabled as a Top Site Search Engine however it incorrectly appears as one like in the comment 0 screenshot.
Priority: P2 → P1
Blocks: 1482959
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/70111e2ac8a3ac17216fa55f72a089332d190d76
Fix Bug 1482629 - Compare search topsites against search engine _internalAliases (#4326)
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
https://hg.mozilla.org/mozilla-central/rev/fcf8f41c1ae2
Target Milestone: --- → Firefox 63
Blocks: 1482398
I have verified that the issue is no longer reproducible in the latest Nightly (63.0a1, Build ID 20180815225731) on Windows 10, Mac 10.13 and Linux x64. The Amazon Top Site is no longer converted to a search Top Site in es-MX builds.
Status: RESOLVED → VERIFIED
I managed to reproduce the issue using an older version of Nightly (2018-08-12) on Windows 10 x64.
I retested everything using beta 62.0b19 on Windows 10 x64, Ubuntu 16.04 x64 and macOS 10.12. The bug is not reproducing anymore.
Depends on: 1498916
No longer depends on: 1498916
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.