When no studies have run, about:studies shows "Nightly may install and run studies" despite studies being disabled

VERIFIED FIXED in Firefox 64

Status

()

defect
--
major
VERIFIED FIXED
8 months ago
8 months ago

People

(Reporter: Oriol, Assigned: mythmon)

Tracking

({regression})

60 Branch
Firefox 65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 wontfix, firefox63 wontfix, firefox64blocking verified, firefox65 verified)

Details

Attachments

(1 attachment)

Reporter

Description

8 months ago
In about:preferences#privacy,

 - Check "Allow Nightly to send technical and interaction data to Mozilla" (datareporting.healthreport.uploadEnabled=true)
 - Uncheck "Allow Nightly to install and run studies" (app.shield.optoutstudies.enabled=false)

Then go to about:studies. A message says

> Nightly may install and run studies from time to time

I need to disable "Allow Nightly to send technical and interaction data to Mozilla" in order to get "No new studies will run."

This is very confusing. If app.shield.optoutstudies.enabled=false alone doesn't prevent studies, then "Allow Nightly to install and run studies" in about:preferences should be changed to explain whatever the pref really does.

Otherwise about:studies should also check app.shield.optoutstudies.enabled instead of just datareporting.healthreport.uploadEnabled.

This started in https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=8fb0418948834f071dd99f6b8256b746b4a8adce&tochange=94f5c92fc711a1e1e76ea54d52482cbbd2db0401
Assignee

Comment 1

8 months ago
Thanks for the bug report. I was able to duplicate what you're seeing as well.

I'm skeptical that the bug started in the changeset you linked, since that commit tends to break history views. I suspect it was pre-existing when we moved all the code around. How did you narrow it down to that changeset?

I'm fairly sure, but haven't verified yet, that we are honoring the preferences in the actual behavior of installing add-ons, and the bug is only related to about:studies. I will also double check about that though.
Summary: "Nightly may install and run studies" despite app.shield.optoutstudies.enabled=false → about:studies shows "Nightly may install and run studies" despite app.shield.optoutstudies.enabled=false
Reporter

Comment 2

8 months ago
(In reply to Michael Cooper [:mythmon] from comment #1)
> I'm skeptical that the bug started in the changeset you linked, since that
> commit tends to break history views. I suspect it was pre-existing when we
> moved all the code around. How did you narrow it down to that changeset?

I used mozregression-gui. Before that changeset, the message box was empty. After the changeset, I started getting "Nightly may install and run studies from time to time" despite app.shield.optoutstudies.enabled=false
[Tracking Requested - why for this release]: we don't want this to get bigger than it already is; should be resolved ASAP.
Flags: needinfo?(mcooper)
Assignee

Updated

8 months ago
Flags: needinfo?(mcooper)
Summary: about:studies shows "Nightly may install and run studies" despite app.shield.optoutstudies.enabled=false → When no studies have run, about:studies shows "Nightly may install and run studies" despite studies being disabled
Assignee

Comment 4

8 months ago
I did more research here, and the problem happens happens specifically when no studies have ever run on the profile. When this is the case, the message chosen doesn't vary based on if studies are enabled or not.

To be clear, the pref is respected: when the preference is changed studies are not installed and existing studies are ended. The bug here is the wrong message being shown only.
Assignee

Updated

8 months ago
Depends on: 1501877
Assignee

Updated

8 months ago
Assignee: nobody → mcooper
Status: NEW → ASSIGNED
Flags: qe-verify+
Severity: normal → major

Comment 6

8 months ago
Pushed by mcooper@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f0ed99b29aaf
Reflect study opt-out in about:studies when Normandy is generally enabled. r=Gijs
Assignee

Updated

8 months ago
See Also: → 1502169

Comment 8

8 months ago
Pushed by mcooper@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9de1bee6adc2
Reflect study opt-out in about:studies when Normandy is generally enabled. r=Gijs

Comment 9

8 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/9de1bee6adc2
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Assignee

Updated

8 months ago
Flags: needinfo?(mcooper)
Please nominate this for Beta approval when you get a chance.
Flags: needinfo?(mcooper)
Assignee

Comment 11

8 months ago
Comment on attachment 9019889 [details]
Bug 1498940 - Reflect study opt-out in about:studies when Normandy is generally enabled. r=Gijs

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: None

User impact if declined: When a user has disabled studies but not Normandy, about:studies incorrectly shows that studies may run.

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: No

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Only a change to the display logic of about:studies, not any of the actual logic of running studies or Normandy

String changes made/needed:
Flags: needinfo?(mcooper)
Attachment #9019889 - Flags: approval-mozilla-beta?
This has conflicts with Beta - do we need bug 1501877 also?
Flags: needinfo?(mcooper)
Assignee

Comment 13

8 months ago
Oops. Yes, we need bug 1501877. We'll also need bug 1502169 to avoid some intermittent test failures. The three patches were developed together and split to separate concerns in review.
Flags: needinfo?(mcooper)
Comment on attachment 9019889 [details]
Bug 1498940 - Reflect study opt-out in about:studies when Normandy is generally enabled. r=Gijs

[Triage Comment]
Fixes a confusing UI issue, approved for 64.0b6.
Attachment #9019889 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Reproduced the issue on Fx65 29-10-2018 / verified as fixed on Nightly 31-10-2018 on Windows 10/Windows 8.1. Given the nature of the fix, I don't think a cross platform verification is required.

With the fix, when "Allow Nightly to install and run studies" is checked off, the about:studies lists: "This is a list of studies that you have participated in. No new studies will run."
Verified as fixed on 64.0b6 2018-11-01 on OSX 10.13/ Windows 10 / Ubuntu 16.04.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.