Closed Bug 1498972 Opened 3 years ago Closed 1 year ago

Opening a search suggestion in new tab automatically switches to it regardless of settings

Categories

(Firefox :: Address Bar, defect, P3)

Desktop
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 1673588

People

(Reporter: flaviomonteiro2013, Unassigned)

Details

(Keywords: ux-consistency, ux-interruption)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

Steps to reproduce:

1. Set firefox to not automatically focus onto new tab pages via Settings page
2. Type a search query in the awesome bar
3. Attempt to open the result (be it a web search, history, or bookmark one) in a new tab by either Ctrl-click or with mouse middle click.

Third step may also be triggered by having browser.search.openintab set to true.


Actual results:

The result is opened in a new tab, but Firefox automatically switches to it rather than opening it in the background. Furthermore, the input is lost when you return to the the previous tab that originated the search.


Expected results:

The tab should've been opened in the background, and the search input shouldn't've been lost.
Component: Untriaged → Address Bar
OS: Unspecified → All
Priority: -- → P3
Hardware: Unspecified → Desktop
Please note that unlike bug 765619, this issue treats this behaviour as an UX bug (ignoring an user setting), rather than a matter of enhancement or adding Yet Another Preference. 

As such, if I may suggest, please don't mark this bug as its duplicate, but rather close the 6-year old issue in favor of this one.
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1673588
You need to log in before you can comment on or make changes to this bug.