Closed Bug 1499135 Opened 10 months ago Closed 10 months ago

ensure 'no browsing context' test in clear.py isn't relying on the previous page runs

Categories

(Testing :: geckodriver, defect, P2)

Version 3
defect

Tracking

(firefox64 wontfix)

RESOLVED WONTFIX
mozilla64
Tracking Status
firefox64 --- wontfix

People

(Reporter: smaug, Assigned: smaug)

References

Details

Attachments

(1 file, 1 obsolete file)

Is this too ugly for now?
Attachment #9017242 - Flags: review?(ato)
Comment on attachment 9017242 [details] [diff] [review]
clear_py_no_browsing_context.diff

Review of attachment 9017242 [details] [diff] [review]:
-----------------------------------------------------------------

r+wc

This should do the trick for the time being.  I’ve filed
https://bugzilla.mozilla.org/show_bug.cgi?id=1499057 to fix the
underlying problem, but feel free to apply this first: I can’t see
it doing any harm.

::: testing/web-platform/tests/webdriver/tests/element_clear/clear.py
@@ +47,5 @@
>      assert value is None
>  
>  
>  def test_no_browsing_context(session, closed_window):
> +    element = Element("foo" . time.time(), session)

Are you sure this works?

I would expect "foo()".format(time.time()) to be more successful.
Attachment #9017242 - Flags: review?(ato) → review+
oops. And lovely. that didn't show up as an error when running the test.
Just a simple concatenation then :)
Assignee: nobody → bugs
Attachment #9017242 - Attachment is obsolete: true
Attachment #9017271 - Flags: review?(ato)
(In reply to Andreas Tolfsen ❲:ato❳ from comment #1)
> I would expect "foo()".format(time.time()) to be more successful.

I assume you meant `"foo{}".format(..)` here.
Duplicate of this bug: 1499159
Blocks: 1499057
No longer blocks: 1478799
(In reply to Henrik Skupin (:whimboo) from comment #4)
> (In reply to Andreas Tolfsen ❲:ato❳ from comment #1)
> > I would expect "foo()".format(time.time()) to be more successful.
> 
> I assume you meant `"foo{}".format(..)` here.

Yes, sorry.  My Mac keyboard option key gets stuck all the time.
Comment on attachment 9017271 [details] [diff] [review]
clear_py_no_browsing_context.diff

Review of attachment 9017271 [details] [diff] [review]:
-----------------------------------------------------------------

This works too, thanks 👍

I’ll clean this up later when I address the underlying problem with
the Element abstraction.
Attachment #9017271 - Flags: review?(ato) → review+
Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/97be1d70d0cd
ensure 'no browsing context' test in clear.py isn't relying on the previous page runs, r=ato
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/13541 for changes under testing/web-platform/tests
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.
See Also: → 1499057
See Also: 1499057
https://hg.mozilla.org/mozilla-central/rev/97be1d70d0cd
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Upstream PR merged
Can't merge web-platform-tests PR due to failing upstream checks:
Github PR https://github.com/web-platform-tests/wpt/pull/13541
* Taskcluster (pull_request) (https://tools.taskcluster.net/task-group-inspector/#/aNfcHWFHRLq-mn8AKgHzPg)
The patch got backed out because it causes test failures and is not needed anytime longer due to the full fix on bug 1499057:

https://hg.mozilla.org/integration/mozilla-inbound/rev/a729ef8fab78
Resolution: FIXED → WONTFIX
No longer depends on: 1499485
You need to log in before you can comment on or make changes to this bug.