Closed Bug 1499333 Opened Last year Closed Last year

Rename all "worker client" to "worker front"

Categories

(DevTools :: Framework, enhancement)

enhancement
Not set

Tracking

(firefox64 fixed)

RESOLVED FIXED
Firefox 64
Tracking Status
firefox64 --- fixed

People

(Reporter: ochameau, Assigned: ochameau)

References

Details

Attachments

(1 file, 1 obsolete file)

Bug 1494632 is going to rename WorkerClient class to WorkerTargetFront, but won't rename all the variables where we pass around a worker client.

I'll handle the renaming of these variables in a distinct bug as it is a very conflicting patch that is likely going to be hard to merge.
This rename should be about doing:
 $ find devtools/ -type f -exec sed -i 's/WorkerClient/workerFront/g' {} \;
 $ find devtools/ -type f -exec sed -i 's/workerClient/workerFront/g' {} \;
And manually rename devtools/shared/webconsole/test/common.js which contains "worker client".

Or should it rather be named "workerTargetFront" rather than "workerFront"?
Note that I'm expecting to eventually merge this WorkerTargetFront class with WorkerTarget/TabTarget.
So it some other places, where we currently use WorkerTarget, the variable is called just "target". And I don't expect any rename in those places.

Also, I'm expecting to simplify/remove most of the code currently managing a "worker client".
I would like the listWorkers to return the worker target front directly (currently it returns an actor ID, which we only translate to a front in attachWorker). And once we merge the Fronts with WorkerTarget/TabTarget we will return the "generic" target object. (which will be the worker target front...) But I'm not sure this explanation makes it any easier to understand?!

Julian, any opinion before I submit a patch for review?
Flags: needinfo?(jdescottes)
I think I would prefer workerTargetFront (or drop the front? just workerTarget?). Since we have a worker actor, it might be confusing otherwise.
Flags: needinfo?(jdescottes)
Assignee: nobody → poirot.alex
MozReview-Commit-ID: 9ev8J4gUYuf
MozReview-Commit-ID: 30eOjbkYyvg
Attachment #9018151 - Attachment is obsolete: true
Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d893e01e4d37
Rename all "worker client" to "worker target front". r=jdescottes
https://hg.mozilla.org/mozilla-central/rev/d893e01e4d37
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
You need to log in before you can comment on or make changes to this bug.