Closed Bug 1499475 Opened 2 years ago Closed 2 years ago

Datepickers in calendar print dialog don't show up anymore

Categories

(Calendar :: Printing, defect)

Lightning 6.6
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: MakeMyDay, Assigned: MakeMyDay)

References

Details

(Keywords: regression)

Attachments

(1 file)

STR:
1. Open calendar print dialog
2. Select custom date range
3. Try to change one of the dates

Expected:
The datepicker shows up to allow to select a date

Observed:
Visually nothing happens. In message in rror console:

> TypeError: this.kMinimonth.update is not a function
> onPopup          chrome://calendar/content/datetimepickers/datetimepickers.xml:340:13
> onpopupshowing   chrome://calendar/content/calendar-print-dialog.xul:1:1

Maybe related to bug 1486051 or bug 1474123.
This fixes the issue.
Assignee: nobody → makemyday
Status: NEW → ASSIGNED
Attachment #9033877 - Flags: review?(philipp)
Attachment #9033877 - Flags: approval-calendar-beta?(philipp)
Blocks: 1474123
N.B. that there is another issue with this dialog atm, so the preview itself is not rendered. I filed bug 1517155 separately for that, since that also an affects ESR.
Attachment #9033877 - Flags: review?(philipp)
Attachment #9033877 - Flags: review+
Attachment #9033877 - Flags: approval-calendar-beta?(philipp)
Attachment #9033877 - Flags: approval-calendar-beta+
Keywords: checkin-needed

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/b87bcf831808
Datepicker doesn't show up in print dialog; r=philipp

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 6.8
You need to log in before you can comment on or make changes to this bug.