Magnifying glass icon is positioned to the right of search input instead of left

VERIFIED FIXED in Firefox 64

Status

()

P2
normal
VERIFIED FIXED
2 months ago
22 days ago

People

(Reporter: yoasif, Assigned: mstriemer)

Tracking

(Blocks: 1 bug, {nightly-community, regression})

unspecified
mozilla64
nightly-community, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox62 unaffected, firefox63 unaffected, firefox64 verified)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

2 months ago
Steps to reproduce:

1. Navigate to about:addons
2. Look for input near "Find more extensions"

What happens:

The magnifying glass icon is positioned to the right of the search input. 

Expected result:

The magnifying glass icon should be positioned to the left of the input, like in about:preferences or in the search engine input available in the Firefox toolbar.
(Reporter)

Updated

2 months ago
Blocks: 1489296
Keywords: nightly-community
(Assignee)

Comment 1

2 months ago
I'm guessing this is on Windows, on a Mac both about:addons and about:preferences are on the left.
Assignee: nobody → mstriemer
Created attachment 9017686 [details]
Screenshot_20181016_230612.png

I'm on Debian Testing and have both.
(Assignee)

Updated

2 months ago
Priority: -- → P2
I believe this bug's summary is wrong. The icon should be on the right because it acts as a submit button. As opposed to other search fields, this one doesn't automatically search while typing.

This rule is messing up the icons: https://searchfox.org/mozilla-central/rev/3d989d097fa35afe19e814c6d5bc2f2bf10867e1/toolkit/themes/shared/extensions/extensions.inc.css#240
Blocks: 1488730
Keywords: regression
(Reporter)

Comment 4

2 months ago
Dão, maybe it makes sense to use a rightward facing arrow on the right if the "takes you to a new place" affordance is important here, like exists on about:home. 

about:home also uses the search engine icon (and not a magnifying glass), but I think in about:addons at least, it makes sense to be consistent with other search inputs, unless we replace the magnifying glass with an addons.mozilla.org favicon (which would solve another issue I have with this search box in 1499514), which would be consistent with about:home. 

The rightward facing arrow as presented in about:home doesn't indicate a "new tab" (since about:home doesn't open new tabs), but neither does the magnifying glass as submit button - at least, it is not obvious to me. It would make more sense to me as a submit button if it were not attached to the text field (more obviously a control, instead of a decoration, like with other search fields).
(Assignee)

Comment 5

2 months ago
Created attachment 9018007 [details]
Bug 1499504 - Always include search icon in search boxes on Mac r?dao
(Assignee)

Comment 6

2 months ago
Created attachment 9018009 [details]
no-search-button.PNG

My patch hides the search button so that it matches about:preferences.
(Assignee)

Comment 7

2 months ago
Comment on attachment 9018009 [details]
no-search-button.PNG

Just noticed dao's comment. I'll remove the icon on the left instead.
Attachment #9018009 - Attachment is obsolete: true
(Assignee)

Comment 8

2 months ago
Created attachment 9018105 [details]
no-extra-search-icon.PNG

Here's the fix on Windows now.
Attachment #9018007 - Attachment description: Bug 1499504 - Hide search button in about:addons search on Windows r?jaws → Bug 1499504 - Only add search icon in about:addons search on Mac r?jaws
Attachment #9018007 - Attachment description: Bug 1499504 - Only add search icon in about:addons search on Mac r?jaws → Bug 1499504 - Always include search icon in search boxes on Mac r?dao

Comment 9

2 months ago
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9a404545425a
Always include search icon in search boxes on Mac r=dao

Comment 10

2 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/9a404545425a
Status: NEW → RESOLVED
Last Resolved: 2 months ago
status-firefox64: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
status-firefox62: --- → unaffected
status-firefox63: --- → unaffected
status-firefox-esr60: --- → unaffected
QA Whiteboard: [good first verify]

Comment 11

a month ago
I Have reproduced this bug with Nightly 64.0a1(2018-10-16) on Windows 10, 64 Bit!
The fix is now verified on latest Beta!

Build ID 	20181108141956
User Agent 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:64.0) Gecko/20100101 Firefox/64.0
QA Whiteboard: [good first verify] → [good first verify] [testday20180914]
Thank you Tanvir!

Based on comment 11, I will mark this issue as Verified fixed.
Status: RESOLVED → VERIFIED
status-firefox64: fixed → verified
You need to log in before you can comment on or make changes to this bug.