Increase the search field’s visibility in the extensions and themes sections

RESOLVED FIXED in Firefox 64

Status

()

enhancement
P2
normal
RESOLVED FIXED
8 months ago
6 months ago

People

(Reporter: emanuela, Assigned: mstriemer)

Tracking

(Blocks 1 bug)

unspecified
mozilla64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 months ago
To increase search field visibility, my recommendations are to: 

- Increase the search field max-width 
--- font-size: from 22em to 32em

- Add a magnifying glass at the beginning of the field

- Add a right-pointing arrow at the end of the field [nice to have]

- Change the placeholder 
--- old: “Search on addons.mozilla.org" new: ’Search addons.mozilla.org'

- Add a label next to the search field
--- label string: “Find more extension”
--- font-size: 1.3rem;
--- font-weight: regular;
--- padding-right: 4px;

- Move the header utility button from the this area to the area below
--- the button is displayed on right side of the main container, no extra paddings or margins

Attach to this bug you find a screen that shows the final state. Please note that this picture shows a series of different improvements relevant to other bugs.
(Reporter)

Comment 1

8 months ago
The right string for the label is "Find more extensions".
Blocks: 1489296
Assignee: ddurst → mstriemer
Priority: -- → P2
(Assignee)

Updated

7 months ago
Duplicate of this bug: 1488749
(Assignee)

Updated

7 months ago
Summary: Increase the search field’s visibility in the extensions section in about:addons → Increase the search field’s visibility in the extensions and themes sections

Comment 4

6 months ago
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9cd889824b1c
Add label to search and move utilities menu in about:addons r=jaws

Comment 6

6 months ago
Backout by shindli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/45299a26e20a
Backed out 5 changesets (bug 1488730, bug 1490366, bug 1488727) for bc failures in | toolkit/mozapps/extensions/test/browser/browser_details.js and  browser/components/enterprisepolicies/tests/browser/browser_policy_disable_flash_plugin.js CLOSED TREE
(Assignee)

Comment 7

6 months ago
There was a bad rebase and a test change that should've been earlier in the series causing these failures. I'm running another try build now, but looks to be fixed and will re-land.
Flags: needinfo?(mstriemer)

Comment 8

6 months ago
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aa4cdd603e44
Add label to search and move utilities menu in about:addons r=jaws

Comment 9

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/aa4cdd603e44
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Depends on: 1499504
You need to log in before you can comment on or make changes to this bug.