Closed Bug 1499923 Opened 2 years ago Closed 2 years ago

Support Exchange servers in account creation dialog

Categories

(Thunderbird :: Account Manager, enhancement, P1)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1499953
Thunderbird 60.0

People

(Reporter: BenB, Assigned: BenB)

Details

In the Thunderbird account creation dialog that automatically finds the email server configuration, we so far don't support Exchange.

Support the AutoDiscover method of Microsoft Exchange servers. It allows to find the Exchange server hostname, which is typically a very odd local name like mex09.example.com that cannot be guessed.

The AutoDiscover returns an XML document that describes various protocols that are supported. IMAP may be one of them. If so, offer an IMAP config.

If the server only supports Exchange-only protocols, offer to install a Thunderbird addon that supports these protocols, and (if accepted by the user), then use this to set up the account.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1499953
You need to log in before you can comment on or make changes to this bug.