URL non responsive when a mail dialog is open (i.e Save As dialog)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: nbaca, Unassigned)

Tracking

Trunk
mozilla1.2alpha
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Branch build 2002-06-04: WinMe

Overview: When a Mail dialog is open, such as the Save As dialog, switch to the
Browser and change to a different website and nothing happens.

Steps to reproduce
1. Open Browser
2. Open Mail
3. Select a message
4. Select File|Save As so the Save As dialog is open but don't do anything else
in this dialog
5. Switch to the Browser
6. Enter another site in the URL text field and press Enter

Actual Results: Nothing happens and the Netscape throbber also does not respond
Expected Results: The throbber should respond and the next website should appear
or make the mail dialogs modal so the user doesn't get into this confused state.

Additional Information:
- linux: ok since I can switch to the browser and the URL responds when I enter
a new website.
- mac X: ok since the secondary dialog is modal and prevents switching to
another window such as the browser.
(Reporter)

Comment 1

17 years ago
Marking nsbeta1 because this can leave the user in a confused state and think
that the browser is not working.
Keywords: nsbeta1

Comment 2

17 years ago
Nav triage team: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → mozilla1.2alpha

Comment 3

16 years ago
*** Bug 221103 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
As described in the bug I just duped, this issue does not appear to be limited
to the Save As dialog or the Mail component. For example, if you have two
browser windows open and select Print in one, you will not be able to navigate
via the URL bar in the other. I think there is an over-arching problem with
modal dialogs, and perhaps the summary of this bug should be updated to reflect
that. Or, this might be a duplicate of such a bug (which I could not find).

Comment 5

16 years ago
Could this be a dupe of bug 74331?

Comment 6

15 years ago
*** Bug 189245 has been marked as a duplicate of this bug. ***
Product: Core → Mozilla Application Suite

Comment 8

14 years ago
Ostgote, I think the two bugs are related but I'm not sure it's a dupe -- 
bug 74331 is about "networking" and I don't know whether the UI response 
qualifies.  But that bug might be filed under the wrong component...
Assignee: bross2 → guifeatures
QA Contact: pawyskoczka

Comment 9

12 years ago
(In reply to comment #8)
> I think the two bugs are related but I'm not sure it's a dupe -- 
> bug 74331 is about "networking" and I don't know whether the UI response 
> qualifies.

Darin marked 74331 as Fixed by the patch for bug 326273 (thread manager).  
I haven't done any testing for 74331, but this bug still manifests with Seamonkey 1.5a-0307.
Filter "spam" on "guifeatures-nobody-20080610".
Assignee: guifeatures → nobody
QA Contact: guifeatures

Updated

11 years ago
Component: XP Apps: GUI Features → UI Design
wfm with Seamonkey2 and Windows vista
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.