[remote-dbg-next] migrate aboutdebugging test: browser_addons_debug_info.js

RESOLVED FIXED in Firefox 66

Status

enhancement
P1
normal
RESOLVED FIXED
7 months ago
4 months ago

People

(Reporter: jdescottes, Assigned: jdescottes)

Tracking

(Blocks 2 bugs)

unspecified
Firefox 66
Dependency tree / graph

Firefox Tracking Flags

(firefox66 fixed)

Details

(Whiteboard: old-remote-debugging-ng-m3)

Attachments

(6 attachments, 1 obsolete attachment)

(Assignee)

Comment 1

6 months ago
filter on remote-debugging-next-move-m3-to-m2
(Assignee)

Comment 2

6 months ago
filter on remote-debugging-next-move-m3-to-m2
(Assignee)

Comment 3

6 months ago
filter on remote-debugging-next-move-m3-to-m2
No longer blocks: remote-debugging-ng-m3
Priority: P3 → P2
Whiteboard: old-remote-debugging-ng-m3
(Assignee)

Updated

4 months ago
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
(Assignee)

Updated

4 months ago
Priority: P2 → P1
(Assignee)

Comment 4

4 months ago
Not strictly needed but I think it makes the component easier to read
(Assignee)

Updated

4 months ago
Depends on: 1520412
(Assignee)

Updated

4 months ago
Duplicate of this bug: 1500368
Attachment #9036630 - Attachment is obsolete: true
(Assignee)

Comment 12

4 months ago

You can have a look at the following documentation for some tips on how to migrate tests: https://gist.github.com/juliandescottes/fecc426ac84600357259bf513cea744c

Comment 13

4 months ago
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/160cc7a53e21
Move addon extension id rendering to dedicated method;r=daisuke
https://hg.mozilla.org/integration/autoland/rev/1a9e703e70d1
Display temporary ID message for tmp webextensions in new aboutdebugging;r=daisuke
https://hg.mozilla.org/integration/autoland/rev/7aa26271b4c5
Add test for temporary id message;r=daisuke
https://hg.mozilla.org/integration/autoland/rev/1c06ef2cea48
Show addon warnings using ErrorMessage;r=daisuke,ladybenko
https://hg.mozilla.org/integration/autoland/rev/76e2d626f740
Test warning messages for addons are displayed in new about:debugging;r=daisuke
https://hg.mozilla.org/integration/autoland/rev/53e88d5a31a7
Rename temporary addon test to be consistent with other addons test;r=daisuke
You need to log in before you can comment on or make changes to this bug.