"Hover" style for links is not in effect when a new page loads with a link under the mouse cursor

VERIFIED DUPLICATE of bug 46388

Status

()

Core
Event Handling
--
trivial
VERIFIED DUPLICATE of bug 46388
16 years ago
15 years ago

People

(Reporter: David Nesting, Assigned: joki (gone))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

When loading a web page in the browser, if the mouse happens to lie on top of a
just-rendered link, that link's "hover" pseudo-style won't be in effect. 
Subsequently moving the mouse a tiny bit will cause the hover style to take
effect.  The URL above is a simple test case that demonstrates this.

Reproducible: Always
Steps to Reproduce:
1. Follow a link to a page, where the mouse is positioned such that it will be
on top of a link on the destination page

Actual Results:  The link's style was left at its default.

Expected Results:  The link's :hover pseudo-style should be in effect.

Comment 1

16 years ago
WFM in the June 12th Windows ME build (2002-0612-05 1.0.0)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

16 years ago
Interesting -- does bug 20022 or bug 112829 also work for you?  I suspect 112829
is another symptom of the same problem.

Comment 3

16 years ago
Reproduced with trunk build 2002061108 on Win2k. Reopening. I can't reproduce
bug 112829 anymore, though.

david@fastolfe.net, can you reproduce bug 112829?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Are you sure you're not seeing the bug that :hover state goes away when you
press a key and stays that way until you move the mouse again?

Comment 5

16 years ago
dbaron: I'm seeing both.
(Reporter)

Comment 6

16 years ago
I cannot reproduce 112829.  So maybe they're not related.  However, in 112829's
test case, if I position the mouse somewhere where a link *could* be, and scroll
the scrollbar until a link appears under the mouse, the :hover state is not in
effect until the mouse is moved.  That may be an unrelated but similar issue though.

Comment 7

16 years ago
> I cannot reproduce 112829.  So maybe they're not related.

Bug 112829 seems to have gone away.

> However, in 112829's test case, if I position the mouse somewhere
> where a link *could* be, and scroll the scrollbar until a link
> appears under the mouse, the :hover state is not in effect until
> the mouse is moved.  That may be an unrelated but similar issue
> though.

I believe that issue is the same as this bug.

This bug is the same as bug 20022 except that this is about content while 20022
is about chrome. Unable to find a dupe; confirming and reassigning to event
handling.
Assignee: attinasi → joki
Component: Layout → Event Handling
QA Contact: petersen → rakeshmishra

Comment 8

16 years ago
(I could have sworn I had checked that Confirm checkbox...)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

16 years ago
*** Bug 154923 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 46388 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
QA Contact: rakeshmishra → trix

Comment 11

15 years ago
verifying dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.