Closed Bug 1500731 Opened Last year Closed Last year

Thunderbird Hungarian locale not showing

Categories

(Thunderbird :: Untriaged, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: ovari123, Unassigned)

Details

(Keywords: intl)

Attachments

(4 files)

Attached image Locale Settings.png
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0

Steps to reproduce:

Linux Mint 19
Thunderbird 60.2.1 64-bit

1. Change the Language Settings in Linux Mint to Hungarian. Ensure that all language packs have been fully installed.
2. Language (felhasználói felület = GUI) is Hungarian
Region is English.
3. Thunderbird opens with an English GUI not Hungarian as seen in the attached picture.
a) Firefox (shown in image) with Menu Bar (red 1) and Tab (green 2) in Hungarian. LibreOffice, GIMP and the DE is also Hungarian.
b) The list of Thunderbird add-ons shown in the Add-on Manager are in Hungarian, but they their GUI is English (see blue 3 in attached image)

Perhaps Thunderbird is getting the GUI language from the Region not the Language in from Linux Desktop Environment. Image to be attached soon.

Thank you


Actual results:

GUI in English.


Expected results:

GUI should be in Hungarian.
Seems to the be source of the bug.

If we remember correctly, the Thunderbird GUI worked correctly in Thunderbird 52.

Thank you
Keywords: intl
So it's an English build with Hungarian language pack? Did you select that language pack with pref intl.locale.requested, see bug 1437480 comment #15.
Linux Mint was installed in English. It was then changed to Hungarian. The Desktop Environment (DE), LibreOffice, GIMP, Mozilla Firefox, Skype, Nemo, etc all changed to Hungarian. The only item that did not change was Thunderbird 60.2.1. When Thunderbird 52.* was installed it too changed to Hungarian.

To change the language only needed to change the Linux Mint Cinnamon DE language setting. There was no need to select "intl.locale.requested". Please re-enable Thunderbird to use the DE language setting like all the other programs.

Perhaps this is the regression as shown at: https://bugzilla.mozilla.org/show_bug.cgi?id=1490598

Thank you
Well, in TB 60 you will need to change "intl.locale.requested". Does that work? From TB 63 onwards you can select the language pack in the UI, see: https://www.thunderbird.net/en-US/thunderbird/63.0beta/releasenotes/, second item, from bug 1491562.

It's not really a Thunderbird bug, this is Mozilla platform territory.

Zibi, what else can we tell the reporter?

P.S.: Language packs not being uploaded to ATN (bug 1490598) is a different issue, you can always download and install it from here:
http://ftp.mozilla.org/pub/thunderbird/releases/60.2.1/linux-x86_64/xpi/hu.xpi
Flags: needinfo?(gandalf)
(In reply to Jorg K (GMT+2) from comment #4)
> Well, in TB 60 you will need to change "intl.locale.requested". Does that work?
No, see image. Please note that image was taken after a restart of Thunderbird.

> From TB 63 onwards you can select the language pack in the UI, see:
> https://www.thunderbird.net/en-US/thunderbird/63.0beta/releasenotes/, second
> item, from bug 1491562.
> 
> It's not really a Thunderbird bug, this is Mozilla platform territory.
Don't understand why FireFox 63 changes the language to the DE setting, no other changes required by the user. Also show in image.

> P.S.: Language packs not being uploaded to ATN (bug 1490598) is a different
> issue, you can always download and install it from here:
> http://ftp.mozilla.org/pub/thunderbird/releases/60.2.1/linux-x86_64/xpi/hu.
> xpi
Would be nice if Thunderbird 60.*+ worked like version 52.* and Firefox.
Well, TB 60 ESR works as FF 60 ESR, but not as FF 63. I installed a Spanish language pack from here:
http://ftp.mozilla.org/pub/thunderbird/releases/60.2.1/win64/xpi/es-ES.xpi, set intl.locale.requested to es-ES and everything is in Spanish now.
Can I see the about:support " Internationalization & Localization " section copy&paste please? It'll help us asess.
Flags: needinfo?(gandalf)
(In reply to Zibi Braniecki [:gandalf][:zibi] from comment #7)
> Can I see the about:support " Internationalization & Localization " section
> copy&paste please? It'll help us asess.

‘Help’ menu → ‘Troubleshooting information’ option:

Internationalization & Localization
Application Settings
Requested Locales      ["hu","en-US"]
Available Locales      ["en-US"]
App Locales            ["en-US","und"]
Regional Preferences   ["hu-HU"]
Default Locale         "und"
Operating System
System Locales         ["hu-HU"]
Regional Preferences   ["hu-HU"]

Seems that “Available Locales” is missing “hu”. Should this be installed as Linux Mint says that the Hungarian language is fully installed (Teljesen telepítve)?

Thank you
FYI, Firefox 63.0 about:support

Nemzetköziesítés és honosítás
Alkalmazásbeállítások
Kért területi beállítások                ["hu-HU","en-US"]
Rendelkezésre álló területi beállítások  ["en-CA","en-GB","en-ZA","hu","en-US"]
Alkalmazás területi beállításai          ["hu","en-US","en-CA","en-GB","en-ZA","und"]
Területi beállítások                     ["hu-HU"]
Alapértelmezett területi beállítás       "und"
Operációs rendszer
Rendszer területi beállításai            ["hu-HU"]
Területi beállítások                     ["hu-HU"]
Wow.

Ok, so to your point. Yes, "hu" missing from "available locales" is the problem here. I don't know where Linux Mint installs the language packs, and you can take a look at your Add-ons page in Thunderbird to see if the langpack is there and if it's enabled, but it should be, and until "hu" shows up in available locales, we can't negotiate down to it.

But.... there's one more thing that I *completely* don't understand and I'm concerned about. It's independent from your problem, but potentially pretty destructive. Why is your default locale "und"? That should *never* happen.

Default locale is the locale you built the program with. You should always build your software with at least one locale so that localization API can fallback on it if all else fails. Your software is built with no locale. I didn't even know Gecko apps can be built this way, but they certainly should never be.

Since we take your default locale from a file `update.locale` in the package [0] I must assume that that's what is in that file. That's pretty bad. I'd love the maintainer of fx/tb package in Linux Mint to consider fixing that.


[0] https://searchfox.org/mozilla-central/source/intl/locale/LocaleService.cpp#562
(In reply to Zibi Braniecki [:gandalf][:zibi] from comment #10)
> Since we take your default locale from a file `update.locale` in the package
> [0] I must assume that that's what is in that file. That's pretty bad. I'd
> love the maintainer of fx/tb package in Linux Mint to consider fixing that.
> 
> 
> [0]
> https://searchfox.org/mozilla-central/source/intl/locale/LocaleService.
> cpp#562

Cc'ing miketwebster who is a developer of Linux Mint. Please help! Thank you
Thanks! Can you also check if the hungarian langpack is enabled in your Thunderbird's addons page?
Hungarian langpack is *not* enabled in the Thunderbird 60.2.1 Add-ons Manager. Further, there are no langpacks in the Thunderbird add-on Manager. The only options showing are: Get Add-ons; Extensions; Themes; Plugins. There is no "Dictionaries" nor "Languages" options.

FYI, Firefox 63.0 does show "Languages" in the "Add-ons Manager".
Download it (see comment #4), install it, set pref intl.locale.requested.
(In reply to Jorg K (GMT+2) from comment #14)
> Download it (see comment #4), install it, set pref intl.locale.requested.

Workaround worked. Thank you

Before spref intl.locale.requested, the message states:
This might void your warranty!
Changing these advanced settings can be harmful to the stability, security, and performance of this application. You should only continue if you are sure of what you are doing.
I accept the risk!

Hence, it would be preferable if Thunderbird 60.* worked without pref intl.locale.requested like Thunderbird 52.* did.

Also, there are no "Dictionaries" yet Thunderbird has the spell checkers for English and Hungarian available when composing an email.

Thank you
> Hence, it would be preferable if Thunderbird 60.* worked without pref intl.locale.requested like Thunderbird 52.* did.

Yes, we're working on the UI for the pref. If you dislike touching prefs directly, you can also open a platform console and type `Services.locale.setRequestedLocales(["hu", "en-US"]);` which does the same plus validates the input.

But we should try to figure out why Linux Mint doesn't install the langpack properly for you.
As I said, UI *was* implemented in TB 63 and TB 64, see: https://www.thunderbird.net/en-US/thunderbird/63.0beta/releasenotes/, second item, from bug 1491562.

I think we won't action anything here and this is not a bug tracker for Mint issues.
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.