Closed Bug 1500733 Opened 10 months ago Closed 10 months ago

Remove FoxEye ImageBitmap extensions?

Categories

(Core :: DOM: Core & HTML, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: baku, Assigned: baku)

References

Details

Attachments

(6 files, 1 obsolete file)

Flags: needinfo?(bzbarsky)
This is not part of the spec and it's not actually supported. We throw a "Not implemented" error.
Assignee: nobody → amarchesini
Flags: needinfo?(bzbarsky)
Attachment #9018885 - Flags: review?(aosmond)
Attachment #9018885 - Attachment is obsolete: true
Attachment #9018885 - Flags: review?(aosmond)
Attachment #9018886 - Flags: review?(aosmond)
Attachment #9018887 - Flags: review?(aosmond)
Attachment #9018890 - Flags: review?(aosmond)
Attached patch part 6 - prefSplinter Review
Attachment #9018891 - Flags: review?(aosmond)
It's fine with me to remove this code if the people who added it don't need it anymore.
Attachment #9018886 - Flags: review?(aosmond) → review+
Attachment #9018887 - Flags: review?(aosmond) → review+
Attachment #9018888 - Flags: review?(aosmond) → review+
Attachment #9018889 - Flags: review?(aosmond) → review+
Attachment #9018890 - Flags: review?(aosmond) → review+
Attachment #9018891 - Flags: review?(aosmond) → review+
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/dac317f3cd31
Remove the support for BufferSource in createImageBitmap, r=aosmond
https://hg.mozilla.org/integration/mozilla-inbound/rev/3c81d4cb6aea
Remove ImageBitmap.mapDataInto, r=aosmond
https://hg.mozilla.org/integration/mozilla-inbound/rev/17ac83c08f67
Remove ImageBitmap.mappedDataLength, r=aosmond
https://hg.mozilla.org/integration/mozilla-inbound/rev/e324b60281dd
Remove ImageBitmap.findOptimalFormat, r=aosmond
https://hg.mozilla.org/integration/mozilla-inbound/rev/8b5a4cd42d40
Remove tests, r=aosmond
https://hg.mozilla.org/integration/mozilla-inbound/rev/1dee16fa95e5
Remove canvas.imagebitmap_extensions.enabled preference, r=aosmond
Blocks: 1338319
Blocks: 1348219
Component: DOM → DOM: Core & HTML
Duplicate of this bug: 1426352
You need to log in before you can comment on or make changes to this bug.