Closed Bug 1501161 Opened Last year Closed Last year

Enabling CSD causes fullscreen tab bar to become transparent

Categories

(Core :: Widget: Gtk, defect)

Unspecified
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- fixed
firefox65 --- fixed

People

(Reporter: yoasif, Assigned: stransky)

References

(Blocks 1 open bug)

Details

(Keywords: nightly-community, regression)

Attachments

(2 files)

Steps to reproduce:

1. Set browser.tabs.drawInTitlebar;true
2. Open any web page
3. Go to full screen

What happens:

The tab bar becomes semitransparent and allows desktop background to be seen.

Expected result:

Tab bar colors should look like it does when not in full screen. 

Screenshot attached. 

11:57.15 INFO: Narrowed inbound regression window from [59d4d986, 9f3cde2c] (3 builds) to [59d4d986, 9bde1b9b] (2 builds) (~1 steps left)
11:57.15 INFO: No more inbound revisions, bisection finished.
11:57.15 INFO: Last good revision: 59d4d98688e4cfd32a267f97720bc7fe07305b07
11:57.15 INFO: First bad revision: 9bde1b9b0810e1c3eb170fbace15eb6aa250b637
11:57.15 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=59d4d98688e4cfd32a267f97720bc7fe07305b07&tochange=9bde1b9b0810e1c3eb170fbace15eb6aa250b637
Blocks: 1493145
Has Regression Range: --- → yes
Has STR: --- → yes
Martin, could you investigate this?
Flags: needinfo?(stransky)
Jared, this looks like a variant of Bug 1447775, should be fixed by Bug 1356920. We can apply a workaround if Bug 1356920 does not land in time.
Assignee: nobody → stransky
Flags: needinfo?(stransky)
Blocks: gtktitlebar
(In reply to Martin Stránský [:stransky] from comment #2)
> Jared, this looks like a variant of Bug 1447775,

I don't think this is true, or at least I don't see how these two are related...
(In reply to Dão Gottwald [::dao] from comment #3)
> (In reply to Martin Stránský [:stransky] from comment #2)
> > Jared, this looks like a variant of Bug 1447775,
> 
> I don't think this is true, or at least I don't see how these two are
> related...

Sure, let's investigate that.

Asif, which system / desktop environment and Gtk+ theme do you run?
Flags: needinfo?(yoasif)
GNOME 3.30.1 on Ubuntu Cosmic
Using the default Adwaita theme; the issue doesn't appear in "Yaru".
Flags: needinfo?(yoasif)
I think I can see that. Let's wait until Bug 1356920 lands.
Depends on: 1356920
Keywords: checkin-needed
Pushed by aciure@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d5edb89adaa1
Set transparent titlebar background for normal sizemode only, r=dao
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d5edb89adaa1
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Does this need a Beta approval request?
Flags: needinfo?(stransky)
Yes please.
Flags: needinfo?(stransky)
Comment on attachment 9023080 [details]
Bug 1501161 - Set transparent titlebar background for normal sizemode only, r=dao

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1493145

User impact if declined: Users can see transparent titlebar when running on Gnome, have disabled system titlebar and browser goes fullscreen.

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Minor style change for Linux/gnome/full-screen mode.

String changes made/needed: none
Attachment #9023080 - Flags: approval-mozilla-beta?
Comment on attachment 9023080 [details]
Bug 1501161 - Set transparent titlebar background for normal sizemode only, r=dao

linux css regression fix, approved for 64.0b11
Attachment #9023080 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [good first verify]
[testday-20181221] 

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0
OS:  Windows 7 (64bit)
Status: Fixed & Verified 

Steps to Reproduce:

1) Start the Firefox 65.0b6 Browser (64-bit) 
2) In new tab, type about:config 
3) In the search option type, search for browser.tabs.drawInTitlebar 
4) Make the value of browser.tabs.drawInTitlebar  - > true 
5) Click on View - > Fullscreen or Press F11 key 

I Dont find any changes in tab. The tab was looking normal like ever. 

I have Reproduced the bug & The bug has been fixed.
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.