[CSD] Enable round corners by default

RESOLVED FIXED in Firefox 64

Status

()

enhancement
P3
normal
RESOLVED FIXED
7 months ago
3 months ago

People

(Reporter: stransky, Assigned: stransky)

Tracking

(Blocks 1 bug, {feature})

Trunk
mozilla64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

7 months ago
Fix at Bug #1489097 is not enough as it's not propagated to js code.

Let's set mozilla.widget.use-argb-visuals when it's not set by user to propagate the settings to browser/themes/linux/browser.css.
It might be better to introduce a media query for this similar to -moz-gtk-csd-available.
(Assignee)

Comment 2

7 months ago
browser/themes/linux/browser.css enables transparent background only when mozilla.widget.use-argb-visuals is set.
We need to set mozilla.widget.use-argb-visuals when it's not set by user to propagate it to browser.css.
(In reply to Martin Stránský [:stransky] from comment #2)
> Created attachment 9010929 [details]
> Bug 1493145 - [CSD] Enable round corners by default - propagate
> mozilla.widget.use-argb-visuals, r=jhorak
> 
> browser/themes/linux/browser.css enables transparent background only when
> mozilla.widget.use-argb-visuals is set.
> We need to set mozilla.widget.use-argb-visuals when it's not set by user to
> propagate it to browser.css.

This means that if you move with your profile from a desktop environment where we use ARGB by default to one where we don't, or vice versa, Firefox will be in the wrong state.
(Assignee)

Comment 5

7 months ago
Replace mozilla.widget.use-argb-visuals pref by -moz-gtk-csd-transparent-background media query at browser.css
to draw transparent background. The media query is set by toolkit code and enabled when compatible
window manager is detected.
(Assignee)

Updated

7 months ago
Attachment #9010929 - Attachment is obsolete: true
(Assignee)

Updated

7 months ago
Summary: [CSD] Enable round corners by default - propagate mozilla.widget.use-argb-visuals → [CSD] Enable round corners by default
Attachment #9010929 - Attachment is obsolete: false
Comment on attachment 9011436 [details]
Bug 1493145 - [CSD] Enable round corners by default by -moz-gtk-csd-transparent-background media query, r=dao

Dão Gottwald [::dao] has approved the revision.
Attachment #9011436 - Flags: review+
(Assignee)

Updated

7 months ago
Attachment #9010929 - Attachment is obsolete: true
(Assignee)

Updated

7 months ago
Keywords: checkin-needed

Comment 8

7 months ago
Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9bde1b9b0810
[CSD] Enable round corners by default by -moz-gtk-csd-transparent-background media query, r=dao
Keywords: checkin-needed

Comment 9

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/9bde1b9b0810
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64

Updated

6 months ago
Depends on: 1501161

Comment 10

3 months ago

This is happening again after updating to Firefox 65.0 in Fedora 29.

https://imgur.com/a/mt44aHs

(Assignee)

Comment 11

3 months ago

Yes, it was reverted due to video playback regression (Bug 1516224) and fixed again in Firefox 66 (Bug 1521012).

You need to log in before you can comment on or make changes to this bug.