Closed Bug 1501302 Opened Last year Closed Last year

TRR: Fix the originAttribute use when doing NS checks

Categories

(Core :: Networking: DNS, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: bagder, Assigned: bagder)

References

Details

(Whiteboard: [necko-triaged][trr])

Attachments

(1 file)

As shown in Bug 1501283, we don't use the originSuffix for NS resolves which is incorrect and makes the TRR blacklist not work as intended. Make sure it gets set to "" for internal NS-checks and use the "right" one for regular blacklist verification resolves.
... when that NS check is used to check the "parent" domain of a
blacklisted host.

Previously, additional TRRblacklist entries due to this would always be
added with the originSuffix "" which was incorrect for all uses of other
suffxes.

MozReview-Commit-ID: EeorQuuRCRX
Pushed by daniel@haxx.se:
https://hg.mozilla.org/integration/autoland/rev/c17a9a391852
TRR: pass on correct originSuffix for NS checks r=valentin
https://hg.mozilla.org/mozilla-central/rev/c17a9a391852
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Depends on: 1503502
You need to log in before you can comment on or make changes to this bug.