Add functionality to detect changes in preferences for new "about:config"

RESOLVED FIXED in Firefox 66

Status

()

enhancement
P3
normal
RESOLVED FIXED
9 months ago
6 months ago

People

(Reporter: vcote, Assigned: Paolo)

Tracking

(Blocks 1 bug)

Trunk
mozilla66
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox65 wontfix, firefox66 fixed)

Details

Attachments

(4 attachments)

Add the ability to watch for changes in the preferences as they happen.
We should also add a test for resetting a localized preference to its default value, checking that it will show an empty string or the localized default value, instead of the locale URL.
Duplicate of this bug: 1500729
Depends on: 1517213
Depends on: 1517507
This updates the user interface for adding new preferences to be closer to the mockup, and makes deleted preferences more similar to rows that are not added yet. This will later make it simpler to react to external changes in the underlying data.

Depends on D15944
Assignee: nobody → paolo.mozmail
Status: NEW → ASSIGNED
Pushed by paolo.mozmail@amadzone.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/20f2bbf59893
Part 1 - Optimize the variables containing the global state. r=bgrins
https://hg.mozilla.org/integration/mozilla-inbound/rev/5b558b35ac4f
Part 2 - Add support for recovering deleted preferences. r=bgrins
https://hg.mozilla.org/integration/mozilla-inbound/rev/2039967a0b3b
Part 3 - Detect changes in preferences. r=bgrins
https://hg.mozilla.org/integration/mozilla-inbound/rev/cd0401ea98ff
Part 4 - Make the filter case insensitive. r=bgrins
See Also: → 1520398
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.