Closed Bug 1501518 Opened Last year Closed Last year

check_ready() panic because the render target texture is smaller than max_size

Categories

(Core :: Graphics: WebRender, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- unaffected
firefox65 --- fixed

People

(Reporter: bholley, Assigned: bholley)

References

Details

(Keywords: crash, regression)

Attachments

(1 file)

This is a regression from bug 1501073. I hit a panic on [1]. Patch forthcoming.

[1] https://projects.fivethirtyeight.com/2018-midterm-election-forecast/house/?ex_cid=rrpromo
(A commit message, which I just added):

    Previously, we sized all render target textures using max_size. This
    changed, and now we size them based on the union of the allocator's used_rect
    for each slice.
    
    At present, the code updates max_size for every render task. But it's
    only used to size the per-slice allocators, which in turn are only used
    for RenderTaskLocation::Dynamic. Accounting for this fixes a panic
    (wherein check_ready can fail because the texture is smaller than
    max_size) and also allows more-efficient render target texture sizing.
Green try push: https://treeherder.mozilla.org/#/jobs?repo=try&revision=4e0b2260f5bc285c6d648b609767992209c78491

This merged on github, waiting for it to hit m-c.
Depends on: 1501525
Is it possible/worth writing a crash test for this?
Verified fixed in the latest osx nightly.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Keywords: crash, regression
Target Milestone: --- → mozilla65
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.