Port bug 1497860 - Move mozconfig variant definitions to taskcluster config.

RESOLVED FIXED in Thunderbird 65.0

Status

defect
RESOLVED FIXED
8 months ago
5 months ago

People

(Reporter: rjl, Assigned: rjl)

Tracking

Trunk
Thunderbird 65.0
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird_esr6065+ fixed, thunderbird64 fixed, thunderbird65 fixed)

Details

Attachments

(3 attachments, 1 obsolete attachment)

Assignee

Description

8 months ago
Bug 1497860 introduced breaking changes to the Taskcluster configuration.

- set default mozconfig_variant in ci/build/kind.yml
- mozconfig_variant overrides need to be moved from mozharness/build/branch_specfics.py to ci/build/{linux,macosx,windows}.yml
- testing/mozharness/configs/builds/taskcluster_sub_win{32,64}/opt.py were removed from M-C, need to update ci/build/windows.yml, need to move those settings to ci/build/windows.yml
Assignee

Comment 1

8 months ago
Ported M-C Taskcluster updates from Bug 1497860 to C-C.

- set default mozconfig_variant in ci/build/kind.yml
- mozconfig_variant overrides need to be moved from
mozharness/build/branch_specfics.py to ci/build/{linux,macosx,windows}.yml
- testing/mozharness/configs/builds/taskcluster_sub_win{32,64}/opt.py were
removed from M-C, need to update ci/build/windows.yml, need to move those
settings to ci/build/windows.yml

Depends on D9603
Assignee

Comment 2

8 months ago
The patch in Phabricator relies on the patch in bug 1501488 being applied first.
Depends on: 1501488

Comment 3

8 months ago
Posted patch D9612.patch (obsolete) — Splinter Review
Rebased for bug 1501488 but not working :-(

I get:
  File "c:\mozilla-source\comm-central\taskcluster\taskgraph\loader\multi_dep.py", line 165, in get_primary_dep
    assert len(dep_tasks) == 1, "Must define a primary-dependency!"
AssertionError: Must define a primary-dependency!

Can't be far off.

Comment 4

8 months ago
Added custom-build-variant-cfg: debug back in as per Tom's comment.
Attachment #9019605 - Attachment is obsolete: true

Comment 5

8 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/5c2052f239d2
Port bug 1497860: Move mozconfig_variant definitions to taskcluster config. rs=bustage-fix
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED

Updated

8 months ago
Target Milestone: --- → Thunderbird 65.0

Comment 6

8 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/13f59980740f
Follow-up: Use 'mozconfig-variant: debug' for Mac as well. rs=bustage-fix
Assignee

Comment 8

8 months ago
[Approval Request Comment]
Regression caused by (bug #): 1501526
User impact if declined: 
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky):

This was missed in the initial porting from M-C. The problem only
affects C-B.
Attachment #9023105 - Flags: approval-comm-beta?
Assignee

Comment 9

8 months ago
For the record, this wasn't caught on the try build because try falls through to the default of '':
https://hg.mozilla.org/mozilla-central/file/tip/taskcluster/taskgraph/decision.py#l233

which is then defaulted to "nightly" at https://hg.mozilla.org/comm-central/file/tip/taskcluster/ci/build/kind.yml#l52

New Try push:
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=46a3829a7eafc4fdc0e597926db2f1ce8d97e0bf

Apparently what I needed was a try_task_config.json file with contents like:
{
  "version": 2,
  "parameters": {
    "optimize_target_tasks": false,
    "release_type": "beta",
    "target_tasks_method": "mozilla_beta_tasks"
  }
}

Comment 10

8 months ago
(In reply to Rob Lemley [:rjl] from comment #8)
> This was missed in the initial porting from M-C. The problem only
> affects C-B.
But we need that on C-C as well, so it's right in the next beta, yes?
Assignee

Comment 11

8 months ago
(In reply to Jorg K (GMT+2) from comment #10)
> But we need that on C-C as well, so it's right in the next beta, yes?

correct.

Comment 12

8 months ago
OK, I'll land it on both when your try is done.
Flags: needinfo?(jorgk)

Comment 13

8 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/36dcdf4f2d5c
Follow-up: Use mozconfig-variant: release for beta. rs=bustage-fix DONTBUILD
Assignee

Updated

8 months ago
Attachment #9023105 - Flags: approval-comm-beta?

Updated

8 months ago
Attachment #9023105 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.