Closed Bug 1501584 Opened Last year Closed Last year

Run jittests for GeckoView on Bitbar and Packet x86-64

Categories

(Firefox for Android :: Testing, enhancement, P3)

x86_64
Android
enhancement

Tracking

()

RESOLVED FIXED
Firefox 66
Tracking Status
geckoview64 --- wontfix
geckoview65 --- wontfix
firefox64 --- wontfix
firefox65 --- wontfix
firefox66 --- fixed

People

(Reporter: cpeterson, Assigned: bc)

References

Details

(Whiteboard: [geckoview:p2])

Attachments

(2 files)

We don't currently run jittests on Android because of test failures in bug 1454918 and bug 1475648.

We'd like to run them on our new GeckoView platforms where possible:

Bitbar ARM32 (Moto G5)
Bitbar ARM64 (Pixel 2)
Packet x86-64

We don't need to test Android x86 if we are testing Android x86-64.
Priority: -- → P3
Whiteboard: [geckoview] → [geckoview:p2]
I think it is time to enable the jittests on mozilla-central for android-hw-p2.

I believe we had already discussed that the pixel2s would be sufficient without the need for running on moto g5 or packet.net emulators.
Assignee: nobody → bob
Status: NEW → ASSIGNED
Attachment #9033795 - Flags: review?(jmaher)
Comment on attachment 9033795 [details] [diff] [review]
bug-1501584-enable-jittests-on-mc.patch

Review of attachment 9033795 [details] [diff] [review]:
-----------------------------------------------------------------

nice
Attachment #9033795 - Flags: review?(jmaher) → review+
Pushed by bclary@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/389460801c5c
Run jittests for opt js shell for arm7, arm64 on android-hw-p2, r=jmaher.
https://hg.mozilla.org/mozilla-central/rev/389460801c5c
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
This didn't actually result in the jit tests running.

jmaher: Do you know off hand what I missed here?
Status: RESOLVED → REOPENED
Flags: needinfo?(jmaher)
Resolution: FIXED → ---
Flags: needinfo?(jmaher)
Thanks Joel.

I guess skip-unless-schedules jittest in the taskgraph along with https://searchfox.org/mozilla-central/source/taskcluster/docs/optimization-schedules.rst and https://searchfox.org/mozilla-central/source/js/moz.build means only run when js/src has changed which will cut the load significantly.

jmaher, cpeterson: Do you think we should go ahead and try to run on inbound and autoland now that the runs are green and we will only run when js/src changes?
Flags: needinfo?(jmaher)
Flags: needinfo?(cpeterson)
oh I forgot about that, so these will only run if js/* is modified which is smart.  I think we should have this on built-projects (i.e. the default rule) and that will help find regressions faster.  It sounds like the js team is already aware of the skipped tests on arm64 which might be concerning.
Flags: needinfo?(jmaher)
Attachment #9033995 - Flags: review?(jmaher) → review+
Pushed by bclary@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c58927f9b3c7
Run jittests for opt js shell for android-hw-p2 on built-projects,r=jmaher.
Flags: needinfo?(cpeterson)
(In reply to Bob Clary [:bc:] from comment #7)
> jmaher, cpeterson: Do you think we should go ahead and try to run on inbound
> and autoland now that the runs are green and we will only run when js/src
> changes?

Since we didn't see any big problems running the subset of jittests that are green on try and central, also running them on inbound and autoland SGTM.
https://hg.mozilla.org/mozilla-central/rev/c58927f9b3c7
Status: REOPENED → RESOLVED
Closed: Last yearLast year
Resolution: --- → FIXED
See Also: → 1552051
You need to log in before you can comment on or make changes to this bug.