Move early betas to use the strict list for the default cookie restrictions

RESOLVED FIXED in Firefox 64

Status

()

defect
RESOLVED FIXED
8 months ago
8 months ago

People

(Reporter: Ehsan, Assigned: Ehsan)

Tracking

(Blocks 1 bug)

unspecified
Firefox 65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 fixed, firefox65 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

8 months ago
This was enabled for Nightly in bug 1501461.
Assignee

Updated

8 months ago
Assignee

Comment 2

8 months ago
Comment on attachment 9019682 [details]
Bug 1501657 - Move early betas to use the strict list for the default cookie restrictions

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Not a regression

User impact if declined: We'd like to test the default cookie restrictions using the strict tracking protection list in Nightly and Beta.

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: Bug 1501461

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): This expands the coverage of the default cookie restrictions feature to cover more third-party trackers, so in theory it increases the risk of users encountering breakage as a result but the pref turns itself off in release so it doesn't jeopardize the final release.

Please note that right now we have no known cases of breakage as a result of this feature, and one of the reasons for making this change is expanding the coverage of this feature in order to try to detect more potential breakage cases and/or increase our confidence in the quality of the feature (in the fact that it really doesn't cause all that much breakage.)

String changes made/needed: None
Attachment #9019682 - Flags: approval-mozilla-beta?
(In reply to :Ehsan Akhgari from comment #2)
> User impact if declined: We'd like to test the default cookie restrictions
> using the strict tracking protection list in Nightly and Beta.

This doesn't sound like a user impact, it sounds like an impact to us. Can you clarify what the impact to our users will be if this isn't taken on Beta?
Flags: needinfo?(ehsan)
Assignee

Comment 4

8 months ago
(In reply to Ryan VanderMeulen [:RyanVM] from comment #3)
> (In reply to :Ehsan Akhgari from comment #2)
> > User impact if declined: We'd like to test the default cookie restrictions
> > using the strict tracking protection list in Nightly and Beta.
> 
> This doesn't sound like a user impact, it sounds like an impact to us.

Yes, exactly.

> Can
> you clarify what the impact to our users will be if this isn't taken on Beta?

No direct impact.  The indirect impact is that will limit our ability to test this configuration with a wide enough audience early enough to gain more confidence for releasing it to 65.  Denying this uplift will therefore shift the risk towards the 65 release which is when we'd like to ship this configuration to all of our users.

I hope this answers the question.
Flags: needinfo?(ehsan)

Comment 5

8 months ago
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7e0e03b9169e
Move early betas to use the strict list for the default cookie restrictions r=francois

Comment 6

8 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7e0e03b9169e
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Comment on attachment 9019682 [details]
Bug 1501657 - Move early betas to use the strict list for the default cookie restrictions

Allows us to run more experiments with default cookie restrictions on the Beta64 audience. Approved for 64.0b4.
Attachment #9019682 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Updated

8 months ago
Depends on: 1507013
You need to log in before you can comment on or make changes to this bug.