Temporary files generated by opening external files with content:// scheme should be sanitized

VERIFIED FIXED in Firefox 65

Status

()

defect
P1
major
VERIFIED FIXED
7 months ago
2 months ago

People

(Reporter: andrei.a.lazar, Assigned: andrei.a.lazar)

Tracking

unspecified
Firefox 66
Unspecified
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 unaffected, firefox65+ fixed, firefox66+ verified)

Details

Attachments

(1 attachment)

Assignee

Description

7 months ago
No description provided.
Assignee

Updated

7 months ago
Blocks: 1499618
Assignee

Comment 1

6 months ago
Implemented cache sanitizing for files generated by handling the content:// scheme.
Assignee

Updated

5 months ago
Keywords: checkin-needed

Comment 2

5 months ago
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2c2abfb19c1a
Temporary files generated by opening external files with content:// scheme should be sanitized r=JanH
Keywords: checkin-needed

Comment 3

5 months ago
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2e855a23cef4
Fix eslint failures for trailing spaces. r=eslint-fix

Comment 4

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/2c2abfb19c1a
https://hg.mozilla.org/mozilla-central/rev/2e855a23cef4
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Assignee

Comment 5

5 months ago
Comment on attachment 9024759 [details]
Bug 1501688 Temporary files generated by opening external files with content:// scheme should be sanitized r=JanH

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1501688

User impact if declined: Cache clearing won't work.

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): It's pretty standalone and won't affect other components

String changes made/needed: -
Attachment #9024759 - Flags: approval-mozilla-beta?
(In reply to Andrei Lazar from comment #5)
> Feature/Bug causing the regression: Bug 1501688

I assume bug 1499618 was intended here.
Comment on attachment 9024759 [details]
Bug 1501688 Temporary files generated by opening external files with content:// scheme should be sanitized r=JanH

[Triage Comment]
Fixes broken cache clearing in Fennec 65. Approved for 65.0b4.
Attachment #9024759 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(In reply to Ryan VanderMeulen [:RyanVM] from comment #6)
> (In reply to Andrei Lazar from comment #5)
> > Feature/Bug causing the regression: Bug 1501688
> 
> I assume bug 1499618 was intended here.

Correct.
Flags: qe-verify+
Tested this with the help of Andrei on a Nightly debuggable build who has the patch included. The folder ContentUri was deleted if we performed a clear cache from settings. Seems that we can't test on 65 Beta due to the fact that bug 1506649 is not fixed yet. I will mark 66: verified and keep the qe-verify flag to test when bug 1506649 is landed.

Updated

5 months ago
Blocks: 1406903

Comment 11

5 months ago
Seems there is a fix for bug 1506649 - Sorina can you check it again pls?
Flags: needinfo?(sorina.florean)
Priority: -- → P1

Verified as fixed on 66.0b3.
Device: HTC Desire 820(Android 6.0.1).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(sorina.florean)
You need to log in before you can comment on or make changes to this bug.