Crash in java.lang.IllegalArgumentException: at android.database.AbstractCursor.getColumnIndexOrThrow(AbstractCursor.java)

RESOLVED FIXED in Firefox 65

Status

()

defect
P1
critical
RESOLVED FIXED
7 months ago
2 months ago

People

(Reporter: calixte, Assigned: andrei.a.lazar)

Tracking

(Blocks 1 bug, {crash, regression, topcrash})

Firefox 64
Firefox 65
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox62 unaffected, firefox63 unaffected, firefox64 disabled, firefox65 fixed)

Details

(Whiteboard: --do_not_change--[priority:high], crash signature)

Attachments

(1 attachment)

Reporter

Description

7 months ago
This bug was filed from the Socorro interface and is
report bp-3bf6035f-60da-4df1-863f-72d990181017.
=============================================================

Java stack trace:

java.lang.IllegalArgumentException
	at android.database.AbstractCursor.getColumnIndexOrThrow(AbstractCursor.java:333)
	at android.database.CursorWrapper.getColumnIndexOrThrow(CursorWrapper.java:87)
	at org.mozilla.gecko.util.ContentUriUtils.getDataColumn(ContentUriUtils.java:135)
	at org.mozilla.gecko.util.ContentUriUtils.getPath(ContentUriUtils.java:101)
	at org.mozilla.gecko.util.FileUtils.getFilePathFromUri(FileUtils.java:291)
	at org.mozilla.gecko.IntentHelper.openNoHandler(IntentHelper.java:504)
	at org.mozilla.gecko.IntentHelper.handleMessage(IntentHelper.java:416)
	at org.mozilla.gecko.EventDispatcher$3.run(EventDispatcher.java:356)
	at android.os.Handler.handleCallback(Handler.java:751)
	at android.os.Handler.dispatchMessage(Handler.java:95)
	at android.os.Looper.loop(Looper.java:154)
	at android.app.ActivityThread.main(ActivityThread.java:6351)
	at java.lang.reflect.Method.invoke(Native Method)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:896)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:786)

There are 8 crashes (from 4 installations) in nightly 64 with buildid 20181016100107. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1406903.

[1] https://hg.mozilla.org/mozilla-central/rev?node=05d8e65ff651
Flags: needinfo?(andrei.a.lazar)
Assignee

Updated

7 months ago
Assignee: nobody → andrei.a.lazar
Flags: needinfo?(andrei.a.lazar)
Devices:
 - Samsung Galaxy S7 (8);
 - Nexus 6P (8.1.0);
 - OnePlus 5T (8.1.0);
 - Nokia 6 (7.1.1);
 - Google Pixel (9);
 - Huawei P9 Lite (6);
 - Huawei MediaPad M2 (5.1.1).

Hello, 

Tested in the following scenarios:
 - Update Nightly using the Play Store and launch;
 - Uninstall and reinstall Nightly from the Play Store;
 - Uninstall and install Nightly from the archive;
 - Steps from Bug 1406903 Comment 0.

In none of these scenarios did Nightly crash on any of the devices I've tested this with. Will continue investigating and come back if anything of relevance pops up.
Hardware: Unspecified → ARM

Updated

7 months ago
Whiteboard: --do_not_change--[priority:high]
Assignee

Comment 2

7 months ago
Added fallback for the cases where trying to obtain a file absolute path from external storage was throwing an exception.
Assignee

Updated

7 months ago
Depends on: 1501688
This is the #3 top crash in Fennec 64b3.

Updated

7 months ago
Priority: -- → P1
Maybe we should just backout bug 1406903 from Beta to give this feature one more version to stabilise?
(In reply to Jan Henning [:JanH] from comment #4)
> Maybe we should just backout bug 1406903 from Beta to give this feature one
> more version to stabilise?

Given the fact that we now have two regressions, this bug and Bug 1502721 it might not be a bad idea. Julien - thoughts?
Flags: needinfo?(jcristau)
Sounds reasonable to me.
Flags: needinfo?(jcristau)
Assignee

Updated

6 months ago
See Also: → 1506649

Updated

6 months ago
Keywords: checkin-needed
That was an r+ with comments.
Keywords: checkin-needed
Seeing that Andrei is away, until next week, I'll fix them and push this myself.
Flags: needinfo?(jh+bugzilla)

Comment 10

6 months ago
Pushed by mozilla@buttercookie.de:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e1e05cf314a3
Crash in java.lang.IllegalArgumentException: at android.database.AbstractCursor.getColumnIndexOrThrow(AbstractCursor.java) r=JanH

Updated

6 months ago
Flags: needinfo?(jh+bugzilla)

Comment 11

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e1e05cf314a3
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65

Updated

2 months ago
Duplicate of this bug: 1532013
You need to log in before you can comment on or make changes to this bug.