Closed Bug 1501699 Opened Last year Closed Last year

Ctrl+Shift+Tab doesn't open the All Tabs panel

Categories

(Firefox :: Tabbed Browser, defect, P1)

63 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- wontfix
firefox64 --- verified
firefox65 --- verified

People

(Reporter: michael.miceli88, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Steps to reproduce:

Press Control+Shift+Tab to activate the visual tab switcher.


Actual results:

The visual tab switcher does not open.


Expected results:

With version 63, the keyboard shortcut control+shift+tab no longer activates the visual tab switcher.  If you activate the tab switcher with control+tab, control+shift+tab will work as expected and go through open tabs in reverse order.
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Hi Michael,
Thank you for taking the time to report this issue.

I verified this using the latest 63 release build (20181018182531) and 65.0a1 Nightly build (20181029100347) on Windows 10, Windows 7 and Ubuntu 18.04, and I can confirm that CTRL+Shift+Tab does no longer work unless CTRL+TAB is enabled prior to it.
 
However, I was not able to reproduce it on MAC OSX, as Command+Shift+Tab works properly. 

I can also confirm that this does not affect 64.0b4 DevEdition latest build (20181025233934) or the last 62.0.3 Firefox release build. 

I'll add this to Firefox: Tabbed Browser component, for a more advised input, but if this is not the proper component, please feel free to change it.
Status: UNCONFIRMED → NEW
Component: Untriaged → Tabbed Browser
Ever confirmed: true
After using the new tab interface for a few days, I understand that with the tab priority now being prioritized by most recently used instead of tab order, control+shift+tab doesn't make as much sense anymore.  I don't know if the official opinion is that it's no longer necessary.  If that's the case, then this ticket can be closed.
(In reply to Michael from comment #2)
> After using the new tab interface for a few days, I understand that with the
> tab priority now being prioritized by most recently used instead of tab
> order, control+shift+tab doesn't make as much sense anymore.

Yeah. That's why control+shift+tab should open the All Tabs panel but this appears to be broken.
Assignee: nobody → dao+bmo
Blocks: 1478646
Status: NEW → ASSIGNED
Keywords: regression
Priority: -- → P1
Summary: Control+Shift+Tab does not open tab switcher → Ctrl+Shift+Tab doesn't open the All Tabs panel
Flags: qe-verify+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/78e41b2cfb21
Don't consume the Ctrl+Shift+Tab event when not actually handling it. r=jaws
https://hg.mozilla.org/mozilla-central/rev/78e41b2cfb21
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Comment on attachment 9022899 [details]
Bug 1501699 - Don't consume the Ctrl+Shift+Tab event when not actually handling it. r?jaws

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: bug 1478646

User impact if declined: Ctrl+Shift+Tab doesn't open the All Tabs panel

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: Yes

If yes, steps to reproduce: Enable "Ctrl+Tab cycles through tabs in recently used order" if it isn't already (it is by default), open enough tabs for the tab bar to overflow, hit Shift+Ctrl+Tab

List of other uplifts needed: -

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): trivial fix

String changes made/needed: -
Attachment #9022899 - Flags: approval-mozilla-beta?
Comment on attachment 9022899 [details]
Bug 1501699 - Don't consume the Ctrl+Shift+Tab event when not actually handling it. r?jaws

trivial regression fix, approved for 64.0b8
Attachment #9022899 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified as fixed on Firefox Nightly 65.0a1 (20181107100135)on Windows 10(x64) and Ubuntu 16.04.
This scenario does not repro on DevEdition 64.0b7 (20181105164654) on Windows 10, but it does on Ubuntu 16.04. Will reverify once 64.0b8 is available.
As stated in comment 10, the issue does not reproduce on DevEdition 64.0b8 (20181108141956)on Windows 10(x64), but I'm still able to reproduce it on Ubuntu 18.04 even with DevEdition 64.0b8 (20181108141956).
Flags: needinfo?(dao+bmo)
Can you provide more details about what exactly you did to reproduce this?
Flags: needinfo?(dao+bmo)
I might have miss understood the issue. 
My understanding of the issue was that selecting Ctrl+Shift+Tab should give the user the option to go through tabs in reverse order, and not use the visual tab switcher, as the case is when using MacOS or Windows. 
Having this said, I still feel there is a behavior consistency issue here in regards to the OS, because as stated above, the specified key combination has a certain result on Windows and MAC OS, but do not trigger the same option on Ubuntu.
Could you please clarify the expected behavior, so I can re-test this issue properly while taking in consideration the proper expected outcome.
Thank you.
Flags: needinfo?(dao+bmo)
(In reply to Paul_B from comment #13)
> I might have miss understood the issue.

Yes.

> My understanding of the issue was that selecting Ctrl+Shift+Tab should give
> the user the option to go through tabs in reverse order, and not use the
> visual tab switcher, as the case is when using MacOS or Windows.

That's wrong, see comment 3.

> Having this said, I still feel there is a behavior consistency issue here in
> regards to the OS, because as stated above, the specified key combination
> has a certain result on Windows and MAC OS, but do not trigger the same
> option on Ubuntu.
> Could you please clarify the expected behavior, so I can re-test this issue
> properly while taking in consideration the proper expected outcome.
> Thank you.

The expected behavior is that the "List all tabs" panel opens.
Flags: needinfo?(dao+bmo)
Thank you for your response. 

After confirming that pressing Ctrl+Shift+Tab should open the "List all tabs" panel, I reverified this issue using the latest builds available [63.0.1 Release(20181030165643), 64.0b9 DevEdition(20181112164519), 65.0a1 Nightly (20181113100051)] and the results are listed below:

Mac OS 10.13: Works as intended on all Fx versions -> The panel opens. The user can navigate through tabs in a reverse order. 

Windows 10: The panel does not open, but the user can go through the tabs in reverse order. Valid on all Fx versions listed above.

Windows 7: Ctrl+Shift+Tab does not trigger any action on 63.0.1 Release build & 65.0a1 Nightly build. The panel does not open on 64.0b9 DevEdition build, but the user can navigate in a reverse order.  

Ubuntu 18.04 & Ubuntu 16.04: Ctrl+Shift+Tab does not trigger any action. The panel does not open. Valid on all Fx versions listed above.

Looking at the above results, especially Ubuntu, I would say that the issue is not fixed, as the combination of keys does not trigger any action, regardless of Fx version, except for MacOS.

Looking at the expected behavior mentioned in comment 14, it would look like the issue is not fixed for Windows either.

@Dão Gottwald - do you see the same results I do? If so, would it be safe to say that this issue has to be reopened and further investigated?
Flags: needinfo?(dao+bmo)
Again, can you please provide the exact steps you executed to reproduce this? Did you follow comment 7?
Flags: needinfo?(dao+bmo)
(In reply to Dão Gottwald [::dao] from comment #16)
> Again, can you please provide the exact steps you executed to reproduce
> this? Did you follow comment 7?

This is becoming a big miss understanding for me. 
In comment 3, you say Ctrl+Shift+tab should open "All Tabs" panel. 
I've listed the actual result for that in comment 15.

Then, you also ask if I followed the STR from comment 7. This are:

(In reply to Dão Gottwald [::dao] from comment #7)
> If yes, steps to reproduce: Enable "Ctrl+Tab cycles through tabs in recently
> used order" if it isn't already (it is by default), open enough tabs for the
> tab bar to overflow, hit Shift+Ctrl+Tab

What I understand from the above STR, is that Ctrl+Tab cycles through tabs in recently used order. This does work, but in a different way across OS-es, as you can observe by looking at the below actual results. As I do not have in-depth knowledge of the feature and just looking at the results (which are not consistent across platforms), I would have to say that it is confusing because it does not explicitly say if the "All tabs" panel should open or not and if this behavior is expected to be different depending on the OS. To me, it looks like a contradiction of comment 3 (that is if Ctrl+Tab should trigger the panel and the user should be able to use the Ctrl+Shift+Tab only after that). 

Nevertheless, here are the actual results for both Ctrl+Tab and Ctrl+Tab+Shift combinations:

On Mac OSX, the "All tabs" panel opened when I selected Ctrl+Shift+Tab. Ctrl+Tab works also.

On Windows 10, "All tabs" panel does not open, regardless of the combination of keys, but I am able to go through tabs in order or in reverse order. I selected Ctrl+Shift+Tab - the panel did not open. I was able to go through tabs in reverse order. I selected Ctrl+Tab - the panel did not open. I was able to go through tabs in order)

Windows 7 -  Nightly & Release: I selected Ctrl+Shift+Tab - Nothing happened. When selecting Ctrl+Tab the panel opens and I'm able to go through tabs in order, or in reverse order if I press Ctrl+Shift+Tab while the panel is opened. DevEdition - the same as the behavior on Windows 10.

Ubuntu - All Fx Versions - I selected Ctrl+Shift+Tab - Nothing happened. When selecting Ctrl+Tab the panel opens and I'm able to go through tabs in order, or in reverse order if I press Ctrl+Shift+Tab while the panel is opened.


If "All tabs panel" does have to open when selecting Ctrl+Tab, then we have an issue on Windows 10/All Fx versions and Windows 7/DevEdition.

If it doesn't have to open, as the user can navigate in order or reverse order as needed, and these key combinations trigger or not the "All tabs" panel depending on OS, there is a consistency issue on Windows 7, as DevEdition works differently from the rest of Fx versions (Release & Nightly).

@Dão Gottwald - could you please clarify this so we can properly mark this issue?
Flags: needinfo?(dao+bmo)
(In reply to Paul_B from comment #17)
> (In reply to Dão Gottwald [::dao] from comment #16)
> > Again, can you please provide the exact steps you executed to reproduce
> > this? Did you follow comment 7?
> 
> This is becoming a big miss understanding for me. 
> In comment 3, you say Ctrl+Shift+tab should open "All Tabs" panel.

Under certain circumstances, yes. That's why you need to follow the steps from comment 7.

> I've listed the actual result for that in comment 15.
> 
> Then, you also ask if I followed the STR from comment 7. This are:
> 
> (In reply to Dão Gottwald [::dao] from comment #7)
> > If yes, steps to reproduce: Enable "Ctrl+Tab cycles through tabs in recently
> > used order" if it isn't already (it is by default), open enough tabs for the
> > tab bar to overflow, hit Shift+Ctrl+Tab
> 
> What I understand from the above STR, is that Ctrl+Tab cycles through tabs
> in recently used order.

Yes, this is the name of the required preference in about:preferences' Tabs section.

> This does work, but in a different way across OS-es,

That's not expected. But without knowing what steps you followed exactly, I can't tell if your results make any sense...
Flags: needinfo?(dao+bmo)
I have reproduced this bug with Nightly 65.0a1 (2018-10-24) on Windows 7, 64 Bit!
This bug's fix is verified with latest Beta and latest Nightly!


Build ID 	20181112164519
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

Build ID 	20181120100045
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0
QA Whiteboard: [bugday-20181114]
This bug seems still to reproduce in Nightly 65.0a1 (2018-11-22) on Mac OSX Mojave 10.14.1. 

> But without knowing what steps you followed exactly, I can't tell if your results make any sense...

I put some steps to reproduce together with expected and actual results:

.:: Scenario 1

**[Prerequisites]:**
- Create a new Firefox profile

**[Steps to reproduce]:**
1. Open the browser (tab 1)
2. Open a new tab (tab 2)
3. Open a new tab (tab 3)
4. Press Ctrl+Tab

**[Expected result]:**
- While still holding the Ctrl key down, the browser should show the All Tabs panel, highlighting the most recently used tab, just like Cmd+Tab opens the Application Switcher with the the application previews highlighting the most recently used application when there are three applications running.
- Further pressing Tab (while still holding the Ctrl key down) should cycle backwards through the All Tabs panel, in order of most recently used tabs.
- Upon releasing the Ctrl key, the browser should switch to the currently highlighted tab in the All Tabs panel (being tab 2 - the most recently used tab - if Tab was only pressed once).

**[Actual result]:**
- Exactly as expected

**[Notes]:**

.:: Scenario 2

**[Prerequisites]:**
- Create a new Firefox profile

**[Steps to reproduce]:**
1. Open the browser (tab 1)
2. Open a new tab (tab 2)
3. Open a new tab (tab 3)
4. Press Ctrl+Shift+Tab

**[Expected result]:**
- While still holding the Ctrl+Shift keys down, the browser should show the All Tabs panel, highlighting the least recently used tab, just like Cmd+Shift+Tab opens the Application Switcher with the the application previews highlighting the least recently used application when there are three applications running.
- Further pressing Tab (while still holding the Ctrl+Shift keys down) should cycle backwards through the All Tabs panel, in order of least recently used tabs.
- Upon releasing the Ctrl+Shift keys, the browser should switch to the currently highlighted tab in the All Tabs panel (being tab 1 - the least recently used tab - if Tab was only pressed once).

**[Actual result]:**
- Nothing happens

**[Notes]:**
- The expected behavior can be achieved by instead pressing Ctrl+Tab and then Ctrl+Shift+Tab twice (Ctrl+Tab to open the All Tabs panel, Ctrl+Shift+Tab to get the highlighted tab back to the currently active tab and then Ctrl+Shift+Tab in order to produce the expected result as per above)
(In reply to fwollsen from comment #20)
> **[Steps to reproduce]:**
> 1. Open the browser (tab 1)
> 2. Open a new tab (tab 2)
> 3. Open a new tab (tab 3)
> 4. Press Ctrl+Tab

These steps are incomplete.

From comment 7:
> Enable "Ctrl+Tab cycles through tabs in recently
> used order" if it isn't already (it is by default), open enough tabs for the
> tab bar to overflow, hit Shift+Ctrl+Tab

Specifically, you didn't open enough tabs for the tab bar to overflow.
Depends on: 1509488
I've identified a case where this does indeed not work. Filed bug 1509488.
> I've identified a case where this does indeed not work. Filed bug 1509488.

Great!

> These steps are incomplete.
> Specifically, you didn't open enough tabs for the tab bar to overflow.

Thanks. Updated with complete steps to reproduce below. Hopefully this is helpful in reproducing potentially different behavior across OS-es:

.:: Scenario 1

**[Prerequisites]:**
- Create a new Firefox profile

**[Steps to reproduce]:**
1. Open the browser (tab 1)
2. Open a new tab (tab 2)
3. Open enough tabs for the tab bar to overflow
4. Press Ctrl+Tab

**[Expected result]:**
- While still holding the Ctrl key down, the browser should show the All Tabs panel, highlighting the most recently used tab, just like Cmd+Tab opens the Application Switcher with the the application previews highlighting the most recently used application when there are three applications running.
- Further pressing Tab (while still holding the Ctrl key down) should cycle backwards through the All Tabs panel, in order of most recently used tabs.
- Upon releasing the Ctrl key, the browser should switch to the currently highlighted tab in the All Tabs panel (being tab 2 - the most recently used tab - if Tab was only pressed once).

**[Actual result]:**
- Exactly as expected

**[Notes]:**

.:: Scenario 2

**[Prerequisites]:**
- Create a new Firefox profile

**[Steps to reproduce]:**
1. Open the browser (tab 1)
2. Open a new tab (tab 2)
3. Open enough tabs for the tab bar to overflow
4. Press Ctrl+Shift+Tab

**[Expected result]:**
- While still holding the Ctrl+Shift keys down, the browser should show the All Tabs panel, highlighting the least recently used tab, just like Cmd+Shift+Tab opens the Application Switcher with the the application previews highlighting the least recently used application when there are three applications running.
- Further pressing Tab (while still holding the Ctrl+Shift keys down) should cycle backwards through the All Tabs panel, in order of least recently used tabs.
- Upon releasing the Ctrl+Shift keys, the browser should switch to the currently highlighted tab in the All Tabs panel (being tab 1 - the least recently used tab - if Tab was only pressed once).

**[Actual result]:**
- Nothing happens

**[Notes]:**
- The expected behavior can be achieved by instead pressing Ctrl+Tab and then Ctrl+Shift+Tab twice (Ctrl+Tab to open the All Tabs panel, Ctrl+Shift+Tab to get the highlighted tab back to the currently active tab and then Ctrl+Shift+Tab in order to produce the expected result as per above)
> > This does work, but in a different way across OS-es,
> 
> That's not expected.

I have reverified this issue using the latest Firefox version builds on Windows 10, Windows 7, Ubuntu 18.04 and Ubuntu 16.04.

It would seem like selecting CTRL+Shift+Tab does not open the panel and the user has the ability to go through the tabs in reverse order just after enabling the panel with CTRL+Tab.

This behavior is consistent across OS-es, except Linux 16.04 (Release and Nightly builds) where selecting Ctrl+Shift+Tab does allow the user to go in a reverse order without opening the panel, therefore without selecting Ctrl+Tab prior, as the case is with all the other OS-es. 
Developer Edition Build on Linux 16.04 works properly.
(In reply to Paul_B from comment #24)
> > > This does work, but in a different way across OS-es,
> > 
> > That's not expected.
> 
> I have reverified this issue using the latest Firefox version builds on
> Windows 10, Windows 7, Ubuntu 18.04 and Ubuntu 16.04.
> 
> It would seem like selecting CTRL+Shift+Tab does not open the panel and the
> user has the ability to go through the tabs in reverse order just after
> enabling the panel with CTRL+Tab.

No, that's not what we want, see comment 3.

There seems to be some confusion about what panels we're talking about. Ctrl+Tab should open the Ctrl+Tab panel whereas Shift+Ctrl+Tab should open the All Tabs panel (the same panel that you get when clicking the dropdown at the end of the tab bar when it overflows).
> There seems to be some confusion about what panels we're talking about.
> Ctrl+Tab should open the Ctrl+Tab panel whereas Shift+Ctrl+Tab should open
> the All Tabs panel (the same panel that you get when clicking the dropdown
> at the end of the tab bar when it overflows).

Yes, you are right. There has been a confusion between the two you mentioned, but I think I understand it properly now. I think I've seen the issue on Linux 16.04 due to an old profile. After opening it with a new one, everything worked properly.

I've opened around 40 new tabs and then selected Ctrl+Shift+Tab -> pressing this key combination 1st focuses the page, after that the address bar and then it opens the "List All Tabs" dropdown. 
If the initial focus is on the address bar, then selecting this combination will open "List All Tabs" dropdown. 
Starting with the next selection of this combination the focus navigates through tabs in a reverse order, starting with the last tab.

The above comment is valid for both Nightly and DevEdition latest builds, on Windows 10, Windows 7, Ubuntu 18.04, Ubuntu 16.04, Mac OS 10.13.6. 

I'm sorry for all the confusion and this comments back and forth. The issue is fixed and verified.
> There seems to be some confusion about what panels we're talking about.
> Ctrl+Tab should open the Ctrl+Tab panel whereas Shift+Ctrl+Tab should open
> the All Tabs panel (the same panel that you get when clicking the dropdown
> at the end of the tab bar when it overflows).

Aha. I did not know that the "All Tabs panel" is not the same as the "Ctrl+Tab" panel. All previous steps-to-reproduce and expected results above I have referenced the "Ctrl+Tab" panel incorrectly as "All Tabs panel". Ultimately, I'd expect the "Ctrl+Tab" panel to show upon clicking "Ctrl+Shift+Tab".

Is there a help doc (even a draft) or some meeting notes / UX study results available to reference as to what is the current intended behavior for Ctrl+Tab and Ctrl+Shift+Tab? Is the behavior modeled after some specific OS tab/application switching UX? Trying to wrap my head around this. Thanks for your patience!
> Is there a help doc (even a draft) or some meeting notes / UX study results available to reference as to what is the current intended behavior for Ctrl+Tab and Ctrl+Shift+Tab? Is the behavior modeled after some specific OS tab/application switching UX? Trying to wrap my head around this. Thanks for your patience!

I see know that there is a bug to update the help documents: https://bugzilla.mozilla.org/show_bug.cgi?id=1506037 - I'll follow that one instead.
Based on previous comments, this bug was verified on Beta 64 and Nightly 65. Removing the qe-verify+ flag.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.