Ctrl+Shift+Tab doesn't work when focus is in the content area

VERIFIED FIXED in Firefox 64

Status

()

defect
P1
normal
VERIFIED FIXED
8 months ago
8 months ago

People

(Reporter: dao, Assigned: dao)

Tracking

Trunk
Firefox 65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox63 wontfix, firefox64 verified, firefox65 verified)

Details

Attachments

(1 attachment)

Looks like we need to handle this in the keydown handler as well (like tabbox does), instead of relying on <key>.
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/40310bdbb670
Use keydown handler instead of <key> for Shift+Ctrl+Tab. r=jaws
https://hg.mozilla.org/mozilla-central/rev/40310bdbb670
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Comment on attachment 9027169 [details]
Bug 1509488 - Use keydown handler instead of <key> for Shift+Ctrl+Tab. r=jaws

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: unclear. This is relevant now because of bug 1473595, but I think the regression is older

User impact if declined: Shift+Ctrl+Tab doesn't work consistently

Is this code covered by automated tests?: Unknown

Has the fix been verified in Nightly?: No

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): We're now handling Shift+Ctrl+Tab in the same event handler as Ctrl+Tab. Not really breaking new ground here.

String changes made/needed:
Attachment #9027169 - Flags: approval-mozilla-beta?
(In reply to fwollsen from comment #6)
> **[Steps to reproduce]:**
> 1. Open the browser (tab 1)
> 2. Open a new tab (tab 2)
> 3. Open a new tab (tab 3)
> 4. Press Ctrl+Shift+Tab

As mentioned in bug 1501699 many times, you need to open enough tabs for the tab bar to overflow.
Comment on attachment 9027169 [details]
Bug 1509488 - Use keydown handler instead of <key> for Shift+Ctrl+Tab. r=jaws

make shift-ctrl-tab work reliably; approved for 64.0b14
Attachment #9027169 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
> As mentioned in bug 1501699 many times, you need to open enough tabs for the tab bar to overflow.

Thanks, I did not know that this particular bug is still about the All tabs panel, which I agree could reasonably only be in play when the tab bar overflows. (Not when pressing Ctrl+Shift+Tab though, but that that is another store better discussed in the original bug on the topic: https://bugzilla.mozilla.org/show_bug.cgi?id=1384251#c4)

Happy to see swift action in squashing this particular bug and uplifting it to 64, nice work!
Hi, I managed to reproduce this issue on Windows 10 Firefox Beta 64.0b13 but I can no longer reproduce it in Firefox 64.0b14 or the latest Nightly 65.0a1 (2018-11-28). I will mark it accordingly.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.