(modifier)l + click: open in new window, open in new tab; functionalities are mutually exclusive

VERIFIED DUPLICATE of bug 85169

Status

--
enhancement
VERIFIED DUPLICATE of bug 85169
17 years ago
10 years ago

People

(Reporter: citrus538, Assigned: jag+mozilla)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

There is no way to configure Mozilla to have a (modifier) + click function open
in new window without destroying open in new tab functionality, and vice versa.

Reproducible: Always
Steps to Reproduce:
"Edit"->"Preferences"->"Navigator"->"Tabbed Browsing"->"Middle-click or
control-click. . ." check box enables one function or the other exclusively.

Perhaps the shift + click could alwas open in new window while ctrl + click
always opens in new tab, as shift + click to download files is (for me) used a
lot less than opening in new tab/window is.  I mean. . .does anyone go around
just shift+clicking every link they see?  "Right click -> Save Link Target As. .
." is provides the same functionality but is slower.  And since opening in new
tab/window is used more often, we should have those functions more accessible
than downloading.
This is a duplicate... (and I personally use shift-click a lot more often than
ctrl-click, since I middle-click to open new windows/tabs).
Assignee: Matti → jaggernaut
Component: Browser-General → Tabbed Browser
QA Contact: imajes-qa → sairuh

Comment 2

17 years ago
I like this idea.

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 85169 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.