Closed Bug 85169 Opened 20 years ago Closed 19 years ago

[RFE] Shift-click should open new browser window

Categories

(SeaMonkey :: General, enhancement)

x86
Windows 2000
enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED WONTFIX

People

(Reporter: petko, Assigned: mpt)

References

Details

(Keywords: access)

Shift-click should open new browser window. Maybe an option of either saving
target as it is now vs. opening new browser window should be fine.
Shift-click should open new browser window. Maybe an option of 'saving target
as...' as it is now vs. opening new browser window should be fine.
Ctrl + click does the job as well (opening link in new window)
Shift + click is IE's method. Implementing this would help entice IE users.
You can use CTRL+click to open a link in a new window.
You can right-click a link and select Open Link in New Window. You can
middle-click a link. What's the problem? Shift-click saves the link to disk, as
it should.
Problem is that I have 2 button mouse with wheel and middle click (clicking the 
wheel) opens the new window which is contrary to bug #22775.
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: access
Summary: Shift-click should open new browser window → [RFE] Shift-click should open new browser window
We already had this debate. A long one.

However, I have a great idea for settling this.  PREFERENCES!!!!!

I recommend we have a new category under Advanced called "Modified Clicking".  
Matthew, please provide some ascii for this.
+--------------------------------------------------------------------+
| Navigator Preferences :::::::::::::::::::::::::::::::::::::::::::::|
+--------------------------------------------------------------------+
|                                                                    |
| +-----------------+-+ Modified Clicking :::::::::::::::::::::::::: |
| |  Languages      | |                                              |
| |  Identity       | | ( ) I like pegboard games       Sh.     Sh.  |
| |  Connection     | |                                  +       +   |
| |  Helper Apps    | |                         Sh. Ct. Ct. Alt Alt  |
| |  Start Pages    | |      Open in New Window ( ) (*) ( ) ( ) ( )  |
| |  Appearance     | |     Open behind current ( ) ( ) (*) ( ) ( )  |
| |  Accessibility  | |             Select text (*) ( ) ( ) ( ) ( )  |
| |  Fonts          | |               Save Link ( ) ( ) ( ) (*) ( )  |
| |  Colors&Effects | |       Copy Link Address ( ) ( ) ( ) ( ) (*)  |
| |  Multimedia     | |           Bookmark Link ( ) ( ) ( ) ( ) ( )  |
| |  Scripts&Windows| |         Link Properties ( ) ( ) ( ) ( ) ( )  |
| |  Privacy        | |                                              |
| |  History&Cache  | | (*) Stop this browser, I want to get off     |
| |::Modified:Cli...| |                                              |
| +-----------------+-+ :::::::::::::::::::::::::::::::::::::::::::: |
|                                                                    |
| [?]                                          ( Cancel ) ((  OK  )) |
+--------------------------------------------------------------------+
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → WONTFIX
lol
Status: RESOLVED → VERIFIED
*** Bug 72442 has been marked as a duplicate of this bug. ***
*** Bug 150234 has been marked as a duplicate of this bug. ***
See also bug 165584, "change default pref for Ctrl+Enter to open page in new tab".
*** Bug 175498 has been marked as a duplicate of this bug. ***
Component: User Interface Design → Browser-General
Phoenix makes shift+click open in a new window and ctrl+click open in a new tab.
 I like it.
Right now, shift+click on a link will open a new window in MSIE 6 (don't know
about MSIE 5), Firefox 0.8 and Opera 7.x. Shift+click in Mozilla will open a
"Save As" dialog window: AFAIK, this is undocumented (at least I can find this
in the help content documents). I wish I could at least configure how
shift+click would work.
In K-meleon 0.8.2, one can edit the accel.cfg accordingly for this
SHIFT LButton = ID_OPEN_LINK_IN_NEW_WINDOW
or
SHIFT LBUTTON = ID_OPEN_LINK_IN_BACKGROUND

I think consistency across browsers (de facto browser standard) or
configurability of such mouse shortcut should be achieved here.
My 2 cents
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.