regressed to OpenGL behavior: Maximized library window becomes transparent/empty (Linux/KDE+GPU Process)

RESOLVED DUPLICATE of bug 1502519

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1502519
8 months ago
Last month

People

(Reporter: darkspirit, Unassigned)

Tracking

(Blocks 2 bugs, {nightly-community, regression})

Trunk
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox63 unaffected, firefox64 disabled, firefox65 disabled)

Details

Attachments

(1 attachment)

Debian Testing, KDE, Xorg, GTX1060.
Win10 (with/without ANGLE) is fine.

STR: Open the library, e.g. Downloads by Ctrl+Shift+Y. Maximize the window.

Actual: The window is maximized but transparent/empty. Unmaximizing makes the window black inside. Both can be fixed by hovering elements.

Expected: The content should adjust to the new window size.

Context: With non-WR OpenGL this is even reproducible with "last good". So WebRender regressed to the state of OpenGL.
mozregression --repo mozilla-inbound --launch 4f55976a9e9115c9f41075843bc48955684364d9 --pref layers.acceleration.force-enabled:true layers.gpu-process.force-enabled:true

Screencast:
mozregression --repo mozilla-inbound --launch 2cee53dd577363866c3cc6ed7baf679a9936abbf --pref gfx.webrender.all:true layers.gpu-process.force-enabled:true

mozregression --good 2018-05-26 --bad 2018-10-26 --pref gfx.webrender.all:true layers.gpu-process.force-enabled:true
> 12:43.28 INFO: Last good revision: 4f55976a9e9115c9f41075843bc48955684364d9
> 12:43.28 INFO: First bad revision: 2cee53dd577363866c3cc6ed7baf679a9936abbf
> 12:43.28 INFO: Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4f55976a9e9115c9f41075843bc48955684364d9&tochange=2cee53dd577363866c3cc6ed7baf679a9936abbf

2018-10-10
> 2cee53dd5773	Jeff Muizelaar — Bug 1496670. Update layout/reftests/async-scrolling/reftest.list for #3173
> bc87d3ddef61	Sotaro Ikeda — Bug 1461239 - Use InvalidateRenderedFrame() when necessary r=nical
> 335625773207	Jeff Muizelaar — Bug 1495902. Create a shared Shaders object for all windows to use. r=jrmuizel
> 7801a4fb37db	Jeff Muizelaar — Bug 1496670. Update webrender to 923ee495bd9b0fda8a4a94c5a6cf42e2f0548731
Reporter

Updated

8 months ago
See Also: → 1502519
Not reproducible with Gnome on Debian Testing.
Either bug 1502519 would fix both OpenGL and WR, or you force WebRender to (again?) do a repaint and wontfix the other bug?
Severity: normal → minor
Priority: -- → P3
Reporter

Updated

6 months ago
See Also: → 1508594
Reporter

Updated

5 months ago
See Also: → 1518796
Severity: minor → normal
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → DUPLICATE
See Also: 1502519
Duplicate of bug: 1502519
You need to log in before you can comment on or make changes to this bug.