Closed Bug 1502585 Opened 2 years ago Closed 1 year ago

Vibrancy broken in Nightly with webrender enabled

Categories

(Core :: Graphics: WebRender, defect)

Unspecified
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- unaffected
firefox65 --- disabled

People

(Reporter: metasieben, Assigned: kvark)

References

()

Details

(Keywords: nightly-community, regression)

Attachments

(1 file)

Todays Nightly[1] (with webrender enabled) seems to have broken vibrancy, the tabbar is displayed as a black bar when using the light-theme.


[1] https://hg.mozilla.org/mozilla-central/rev/3dc7cdbb2b5fe3cbbe34b19fc32b3562b6ff6ff9
Component: Theme → Graphics: WebRender
Product: Firefox → Core
mozregression --good 2018-10-24 --bad 2018-10-28 --pref gfx.webrender.all:true -a about:addons
> 11:14.83 INFO: Last good revision: e02bbef03c88272b754768d0f7a0c2252e5c93e2
> 11:14.83 INFO: First bad revision: 4ee89e659d382b1052dca58c955dd675c9f2a80f
> 11:14.83 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=e02bbef03c88272b754768d0f7a0c2252e5c93e2&tochange=4ee89e659d382b1052dca58c955dd675c9f2a80f

> 4ee89e659d38	WR Updater Bot — Bug 1502344 - Update webrender to commit 2537e5f27c2ce7b64a93498c7569a870c190feda. r=kats

= https://github.com/servo/webrender/pull/3233
Blocks: 1502344
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(kvark)
Duplicate of this bug: 1502901
Duplicate of this bug: 1502824
Assignee: nobody → kvark
Status: NEW → ASSIGNED
Flags: needinfo?(kvark)
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dfef52a23607
Update webrender to commit e162264c2c2c1bbc3e57429e015af45018f1023b (WR PR 3252). r=kats
Duplicate of this bug: 1503545
Duplicate of this bug: 1501891
https://hg.mozilla.org/mozilla-central/rev/dfef52a23607
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Duplicate of this bug: 1503619
Duplicate of this bug: 1503679
You need to log in before you can comment on or make changes to this bug.