Closed Bug 1502772 Opened 1 year ago Closed 1 year ago

WinUtils::WriteBitmap should use BITMAPV4HEADER (v4+ header)

Categories

(Core :: Widget: Win32, defect)

Unspecified
Windows
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox65 --- disabled
firefox66 --- fixed

People

(Reporter: m_kato, Assigned: m_kato)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Native toast notification uses WinUtils::WriteBitmap to bitmap for notification now.  Since it uses old BITMAPINFOHEADER structure, it doesn't support alpha.  So some notification bitmap's background color is black, not transparent.
s/to bitmap/to write bitmap/
Native toast notification uses WinUtils::WriteBitmap to bitmap for notification now.  Since it uses old BITMAPINFOHEADER structure, it doesn't support alpha.

So I would like to support alpha value to WinUtils::WriteBitmap.
Would it be better to use the encoder that's in imagelib and get rid of this code?
(In reply to Timothy Nikkel (:tnikkel) from comment #3)
> Would it be better to use the encoder that's in imagelib and get rid of this
> code?

Yes, it is nice that imagelib has encoder that saves bitmap v4+.  Notification and setting wallpaper use this utility method.
Assignee: nobody → m_kato
Pushed by m_kato@ga2.so-net.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/5fce19a3307f
WinUtils::WriteBitmap should use BITMAPV4HEADER (v4+ header) r=aklotz
https://hg.mozilla.org/mozilla-central/rev/5fce19a3307f
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Duplicate of this bug: 1508167
Is this something we should consider uplifting to Beta or can it ride the trains?
Flags: needinfo?(m_kato)
Answering my own question, this is still only enabled on Nightly builds, so I'm going to say no to that question.
Flags: needinfo?(m_kato)
Regressions: 1539348
You need to log in before you can comment on or make changes to this bug.