Closed Bug 1502974 Opened 4 years ago Closed 4 years ago

Fix typo in _substituteDefaulThemeIfNeeded

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1429488

People

(Reporter: dao, Assigned: yozaam, Mentored)

References

Details

(Keywords: good-first-bug, Whiteboard: [lang=js])

From bug 1502096 comment 6:

> There's a typo, _substituteDefaulThemeIfNeeded is missing a `t` between
> Defaul and Theme.

This should be fixed in toolkit/mozapps/extensions/LightweightThemeManager.jsm.
May I please solve this bug
(In reply to yozaam from comment #1)
> May I please solve this bug

Sure! Let me know if you have questions.
Assignee: nobody → yozaam
Sir, I have sent a PR on GitHub, is that the right way contribute?
(In reply to yozaam from comment #3)
> Sir, I have sent a PR on GitHub, is that the right way contribute?

I am very sorry for using GitHub it is my first time and I made a mistake, I did not realize GitHub was read only.

I have read https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/How_to_Submit_a_Patch 

I am just slightly confused and wanted to ask where to request a review?
(In reply to yozaam from comment #4)
> I am just slightly confused and wanted to ask where to request a review?

Reviews are handled in Phabricator. You can submit patches to Phabricator using moz-phab or Arcanist:

https://moz-conduit.readthedocs.io/en/latest/phabricator-user.html#using-moz-phab
yozaam, are you still working on this?
Flags: needinfo?(yozaam)
(In reply to Dão Gottwald [::dao] from comment #6)
> yozaam, are you still working on this?

Yes Sir, I am having trouble sending code when I am using phabricator where do I have to push my code and do I have to create a prject of the entire /toolkit on my machine and then or do only have to send for review the code of LightweightThemeManager.jsm,
I am very sorry for asking you such silly questions I don't deserve your help but could you guide me as to what my local project should be
Flags: needinfo?(yozaam)
(In reply to yozaam from comment #7)
> (In reply to Dão Gottwald [::dao] from comment #6)
> > yozaam, are you still working on this?
> 
> Yes Sir, I am having trouble sending code when I am using phabricator where
> do I have to push my code and do I have to create a prject of the entire
> /toolkit on my machine and then or do only have to send for review the code
> of LightweightThemeManager.jsm,
> I am very sorry for asking you such silly questions I don't deserve your
> help but could you guide me as to what my local project should be

I basically wanted to know if I needed to clone the entire mozzilla-central as my project locally and teh nchange only the one file and send it for review?
Yes, you need to clone all of mozilla-central: https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Source_Code
::dao Thank you very much for your patience with me, after installing, cloning, understanding how everything works, all thanks to you.
 I noticed that JanH solved this bug in Bug 1429488 when he submitted D10728 https://phabricator.services.mozilla.com/D10728 and this is no longer a typo in toolkit/mozapps/extensions/LightweightThemeManager.jsm so we can close/cancel this bug
Thank You very much for guiding me, I will surely find another first bug to work on and begin my open source journey
Flags: needinfo?(dao+bmo)
Alright, good job on figuring out that bug 1429488 fixed this!
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(dao+bmo)
Resolution: --- → DUPLICATE
Duplicate of bug: 1429488
You need to log in before you can comment on or make changes to this bug.