Closed Bug 1503184 Opened Last year Closed Last year

Merge TabTarget and WorkerTarget

Categories

(DevTools :: Framework, enhancement, P2)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1503628

People

(Reporter: ochameau, Assigned: ochameau)

References

Details

(Whiteboard: dt-fission)

In order to be able to merge target classes with their front classes, we should first merge TabTarget and WorkerTarget so that there is a unique "target" interface fronts can inherit or compose with.

The goal here is to have only one Target class and so merge TabTarget and WorkerTarget. If some code need to be specific to one target kind, this code should be moved to the front rather than the generic target class.
Severity: normal → enhancement
Priority: -- → P2
Assignee: nobody → poirot.alex
Whiteboard: dt-fission
Oops, I'm getting old, I forget about the bug I open...
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1503628
You need to log in before you can comment on or make changes to this bug.