Closed Bug 1503253 Opened 1 year ago Closed 4 months ago

[RTL] Left align on about:support page in RTL builds

Categories

(Firefox :: General, defect, P3)

64 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- wontfix
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- wontfix
firefox67 --- wontfix
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- verified

People

(Reporter: zstimi, Assigned: itiel_yn8)

References

(Regression)

Details

(Keywords: regression, rtl)

Attachments

(2 files)

Attached image RTLaboutsupport.png
[Affected versions]:
- Firefox 61
- Firefox 62
- Firefox 63
- Firefox 64.0b5
- Firefox nightly 65.0a1

[Affected platforms]:
- Windows 10 x64
- Mac OS X 10.13
- Ubuntu 16.04 x64

[Steps to reproduce]:
1. Download and start Firefox on an RTL arabic build from here: https://archive.mozilla.org/pub/firefox/candidates/64.0b5-candidates/build1/win64/ar/ 
2. Access the about:support page

[Expected result]:
- Everything on this page is align from right to left.

[Actual result]:
- The first column is align from left to right and the second from right to left 
(see: RTLaboutsupport.png)

[Additional notes]:
- I've managed to reproduce this with RTL builds like: "ar", "fa" or "he". 
- Also this issue is not reproducible from Fx55 to Fx60 and Fx60.3.0esr unaffected.
This is a result of this CSS rule:

https://searchfox.org/mozilla-central/rev/eac6295c397133b7346822ad31867197e30d7e94/toolkit/themes/shared/in-content/info-pages.inc.css#162

which explicitly suggests that this is so file-paths are displayed LTR. Because of how mixed LTR/RTL works and has given us issues with URLs, I could imagine that just removing or overriding this rule here would cause problems because file paths contain mixed-directionality characters (like dir separators). A lot of the content in the screenshot is Latin text, and effectively en-US, so I don't think this is necessarily wrong...

I don't know that a lot needs to change here, and if it does, what exactly we should change. Itiel, can you maybe expand on how you think about:support should look in RTL, and what we could change here to make the experience better for RTL users?
Flags: needinfo?(itiel_yn8)
Keywords: rtl
Priority: -- → P3
Thanks for asking!
This reminds me of bug 1329433.

I may be asking too much, but this is what I think should be ideal for RTL in this page:
1. Wherever non-latin characters are not expected, hardcode (the text only) to LTR. That's including file paths, which is an exception. But they all should still be aligned to the right.
2. All table headers (in blue) should be aligned to the right (if not centered). That's the current behaviour.
3. Localized RTL text should of course be RTL, by all means.
That should cover all text in about:support I think.

I'd rather have the Important Modified Preferences' actual preferences in LTR as these are sorted alphabetically and I think the human eye will be able to better locate any individual if they'd be in LTR, but as the 'value' column contents then would also have to be LTR, this will just look wrong. So I dropped this idea.
Flags: needinfo?(itiel_yn8)
I managed to found a regression range manually: 
               Last Good: 20180402220122 
               First Bad: 20180403220040   
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=445255800255bb13ed096b5b7da36aa835e41dd8&tochange=00bdc9451be6557ccce1492b9b966d4435615380  

Maybe this bug caused the issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1373921
Has Regression Range: --- → yes
Flags: needinfo?(dao+bmo)
Keywords: regression
Blocks: 1373921
Flags: needinfo?(dao+bmo)
Assignee: masterkrombi → jaws
I didn't read in to the bug enough and now see that this is unrelated to the Fluent conversion. I don't have time to work on this right now.
Assignee: jaws → nobody
Status: ASSIGNED → NEW
No longer depends on: 1507595
Flags: needinfo?(itiel_yn8)
Assignee: nobody → itiel_yn8
Status: NEW → ASSIGNED
Flags: needinfo?(itiel_yn8)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/c9dc0db9e9a5
Align the appropriate about:support table cells to the right for RTL r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Flags: qe-verify+

I can confirm this issue is fixed, I verified using Firefox 71.0b4 on Win 8.1 x64, Ubuntu 18.04 x64 and macOS 10.14.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.